CSS rendering needs major improvement!

VERIFIED INVALID

Status

()

Core
Layout
P3
normal
VERIFIED INVALID
19 years ago
18 years ago

People

(Reporter: Danny Dorris, Assigned: buster)

Tracking

({compat, testcase})

Trunk
x86
Windows 98
compat, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Go to http://homepage.davesworld.net/~dennisb/ in Mozilla. The page uses a lot
of CSS and obviously doesn't look right. Now go view it in IE. Much better huh?
Looks like your CSS needs major improvement. The problem is the padding to the
right is making the CSS too big I think.

Comment 1

19 years ago
Created attachment 4923 [details]
Testcase

Updated

19 years ago
Keywords: testcase
The page cited is designed for a bug in IE/NN.  The CSS 'width' property
specifies content width, not border width.

Comment 3

19 years ago
Yup, just what David says. As far as the width of the absolutely positioned 
element goes, we're calculating it correctly

I'm leaving this bug open because there are some issues about vertical spacing 
that I need to investigate
(Assignee)

Comment 4

18 years ago
troy, could you add some detail about why this bug is still open and what you 
need to do to fix it?  Thanks.

Comment 5

18 years ago
If you compare the way we render the page to how Nav renders the page you'll see 
for example that the "Hot Topics" section is rendered taller than it is in Nav.

It think the problem is a compatibility problem with the block/inline code, 
because the content looks like this:

<div id="sidebar">
    <p><b>Hot Topics</b></p>
</div>

However, because the div is absolutely positioned I wanted to look at it first 
and better understand it before reassigning it to you
Reassigning to buster - Triaging Troy's bug list
Assignee: troy → buster
(Assignee)

Comment 7

18 years ago
notes from Troy:
<P> has a top margin in html.css.  Kipp added this as a way to emulate Nav (and 
IE) behavior.  But it's not the right solution.
It should get surpressed for all margin roots.
So rather than having this in html.css, we need code in block frame that special 
cases <P> (maybe only in quirks mode?)  This special case should probably only 
effect elements where no top margin has been set.
Status: NEW → ASSIGNED
Summary: CSS rendering needs major improvement! → [P-Margin] CSS rendering needs major improvement!
Target Milestone: --- → M17
Marking compat & nsbeta3. I think we'd better fix this for FCS b/c as the cited 
example demonstrates, sites are depending on this Nav4 behavior to format their 
pages & position navigational links and such.
Keywords: compat, nsbeta3
Sorry, forgot to mention: recc. nsbeta3+.
(Assignee)

Comment 10

18 years ago
The vertical margin issue on this page is fixed, a dup of 35772.  So I've 
removed the [P-Margin] marker.
However, the page still does not lay out as in Nav4 (which is way wrong) or IE 5 
(which is as the author intends, but as David and Troy point out, not properly 
to CSS spec.)  I think this bug is invalid.  eric, do you agree?
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Keywords: nsbeta3
Resolution: --- → INVALID
Summary: [P-Margin] CSS rendering needs major improvement! → CSS rendering needs major improvement!

Comment 11

18 years ago
Works for Me & Renders it according to the specs...its the page thats the problem.
Platform: PC
OS: Windows 98
Build # 2000100508 M18 Trunk Build
Marking as Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.