Can't dag and drop live bookmarks in the bookmark toolbar

VERIFIED DUPLICATE of bug 264200

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 264200
14 years ago
12 years ago

People

(Reporter: tracy, Assigned: vlad)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
seen on windows branch build 2004-10-18-07-0.9

-attempt to drag and drop the default Latest Headlines Live Bookmark to another
location in the Bookmakrs toolbar.

Tested results: clicking on the Live bookmark brings up the list of articles in
the feed.  The Bookmark can't be drag and dropped

Expected results: should somehow be able to drag and drop the Live Bookmark to
another location on the toolbar.
This has been addressed in probably 5-10 other bugs already.  Dragging Live
Bookmarks works the same as dragging folders.  You have to hold Shift to drag
them anywhere.  This has a practical reason, as it allows the user to hold down
the mouse button as they move through the menu, and release on the target.  pch
implemented shift as a stopgap until we can do better drag tracking, but the
menu code is pretty much duct tape and Bondo at the moment.

Either this is INVALID, since you can drag them, or a dupe of the bug on making
the menu stuff allow for differentiating between horizontal/vertical dragging. 
I don't really have the time to dig that old chestnut up myself.

In either case, not something that we should be failing on.  Note that Linux
drag'n'drop is horribly broken, which is something we decided we'd have to
accept because of said duct-taped menu code.

*** This bug has been marked as a duplicate of 264200 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

14 years ago
verified 
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.