unable to focus or toggle tree twisties in Preferences

VERIFIED INVALID

Status

()

Firefox
Keyboard Navigation
P1
normal
VERIFIED INVALID
14 years ago
7 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Aaron Leventhal)

Tracking

({access, helpwanted, regression})

1.0 Branch
x86
All
access, helpwanted, regression
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PrefWindowV)

(Reporter)

Description

14 years ago
found using 2004101809-0.9+ bits on linux fc2. this was not a problem with
firefox 1.0PR.

1. open the Preferences (Options) dialog. go to a panel which contains trees
such as Privacy or Advanced.

2. hit the tab key and try to move focus to one of the tree twisties, for example:

* Privacy > History
* Advanced > Accessibility
* etc...

expected: you should be able to move focus to the "History" (or "Accessibility"
or whichever tree twisty).

actual results: focus cannot be moved using the keyboard (tabbing or up/down
arrow keys) to the tree twisties. because of this, I'm also unable to expand or
collapse the twisties using the keyboard (eg, right/left arrow keys).

need to use the mouse to expand/collapse the tree twisties within Preferences.

interestingly, this isn't a problem in the Bookmarks Manager, which also
contains tree twisties: keyboard shortcuts to expand/collapse the trees work,
and I can move focus amongst them.
(Reporter)

Comment 1

14 years ago
nominating as this is a regression. will find regression window in a bit.
Flags: blocking-aviary1.0?
Version: unspecified → 1.0 Branch
(Reporter)

Comment 2

14 years ago
Tracy or Asa, could you check to see if this is a problem on Windows as well?
thanks! this bug would affect this test:

http://testrunner.mozilla.org/test.cgi?run_id=571#1034

Comment 3

14 years ago
When I did this test, at first glance, I thought I was seeing it on Windows too.
 But it seems that Tab moves through all the items in the options window; first
the Main Five menu items and then into the other widgets of the opened menu item.  

Is it a bug or is it intentional?
(Reporter)

Comment 4

14 years ago
Tracy, are you able to move focus to the twisty and its associated label? that
is, in say the Advanced panel are you able to move focus to the "Accessibility,"
"Browsing," "Tabbed Browsing," "Software Update," widgets?

I can move focus to the *children* of these items, I just cannot move focus (or
toggle the state) to these *parent* items --I don't remember what the
appropriate term would be (tree twisty, top of tree, ?).

Comment 5

14 years ago
This works for me (I think) on windows branch build from this morning. I can tab
into the tree panel and through each of the trees with enter expanding and
collapsing the trees. I'll check linux next. 

Comment 6

14 years ago
On linux I can get the focus to all of the trees and their child elements but I
don't get a focus ring so it's difficult to see what has the focus. That could
be a bug on my system (running FC3 T3 64-bit). I tested today's branch bits. 
(Reporter)

Comment 7

14 years ago
I'm using the default (gnomestripe) theme with today's build in a fresh profile.
hm, could this possibly be a theme issue (there've been quite a few changes
there recently)?
Flags: blocking-aviary1.0? → blocking-aviary1.0-
(Reporter)

Comment 8

14 years ago
okay, looks like this has been around since at least the 9/21 aviary1.0 branch
builds. (not as recent as I had thought.)

Comment 9

14 years ago
On Windows, I can move through these all the items with tab and shift+tab.  The
current item is surrounded by a dotted line. Radio buttons of choices have to be
moved through with the arrow keys. (I think that's normal)
I see what Asa sees (comment 6), linux gtk2 firefox aviary 2004-10-18-20Z,
default fx theme, industrial gtk theme. I.e. all is kb-navigable, but no focus
indication on the twisties or their labels.
(Assignee)

Comment 11

14 years ago
May go away in PrefWindow V but I want to be sure.
Flags: blocking-aviary1.1?
Keywords: helpwanted
OS: Linux → All
Priority: -- → P1
(Assignee)

Updated

14 years ago
Whiteboard: PrefWindowV
No longer a bug (see new prefwindow)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.