en-dash and em-dash too narrow

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Felix Wiemann, Assigned: smontagu)

Tracking

Other Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041017 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041017 Firefox/0.10.1

en-dash and em-dash are both rendered too narrow.  Look at:

-<br>&ndash;<br>&mdash;

The second dash (&ndash;) should be twice as wide as the first dash, but
it's rendered like a normal hyphen.

The third dash (&mdash;) should be four times as wide as the first dash, but
it's rendered like an en-dash.

Reproducible: Always
Steps to Reproduce:

Updated

13 years ago
Assignee: firefox → nobody
Component: General → Layout: Fonts and Text
Product: Firefox → Browser
QA Contact: firefox.general → core.layout.fonts-and-text
Version: unspecified → Other Branch
(Assignee)

Comment 1

13 years ago
Do you have a font with the en dash and em dash? The transliterator
(http://lxr.mozilla.org/seamonkey/source/intl/unicharutil/tables/transliterate.properties#44)
replaces en-dash by "-" and em-dash by "--". It might be better to use "--" and
"----", or "--" and "---".
(Reporter)

Comment 2

13 years ago
I'm not entirely sure if my font has an en-dash and em-dash.

From the transliterator document it looks like an em-dash would be rendered as
two separate normal dashes, which is not the case on my system.

> It might be better to use "--" and "----", or "--" and "---".

Definitively.  I'd suggest "--" and "---", because four dashes looks a little
bit too wide (there is some space between the dashes, after all) and I've seen
three dashes more often.
(Assignee)

Comment 3

13 years ago
Created attachment 162526 [details] [diff] [review]
patch to gentransliterate.pl

Regenerating transliterate.properties with this change adds lots of lines,
including many outside the BMP. Jungshik, do you know if the transliterator
will handle these characters correctly, or should I use an older version of
UnicodeData.txt for now?
Assignee: nobody → smontagu
Status: UNCONFIRMED → ASSIGNED
(Assignee)

Comment 4

13 years ago
Fixed by bug 288137
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.