port 80 is blocked until restart after browing at some sites via firefox

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Eli, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040911 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040911 Firefox/0.10.1

When browsing many sites, which I couldn't really classify, but have noticed to
be mainly forums, port 80 is blocked on the computer until restart. All other
ports work, the said sites do not cause any problems with explorer and are
generally perfectly good and legitimate sites such as www.graphics.ru. After the
occurance of the but the reinstall of network card drivers, physical reconnect
fails to repair a complete blocakade of data transfer at port 80 (all internet
sites report as not responding on both IE and Firefox, exemli gratia) and any
attempt to establish any kind of socket on that port fails, all that is repaired
after a restart of the system.

-Eli Levin

Reproducible: Always
Steps to Reproduce:
1. Browse the site graphics.ru on my computer
2.
3.

Actual Results:  
port 80 is blocked to all traffic

Expected Results:  
not block port 80
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041024 Firefox/1.0

->WFM
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041024
Firefox/1.0
> 
> ->WFM

This site indeed works in other installations of firefox I tried, but it doesn't
yet show that it's not a bug. It's just an elusive one.
Product: Browser → Seamonkey
(Reporter)

Comment 3

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040911 Firefox/0.10.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040911 Firefox/0.10.1
> 
> When browsing many sites, which I couldn't really classify, but have noticed to
> be mainly forums, port 80 is blocked on the computer until restart. All other
> ports work, the said sites do not cause any problems with explorer and are
> generally perfectly good and legitimate sites such as www.graphics.ru. After the
> occurance of the but the reinstall of network card drivers, physical reconnect
> fails to repair a complete blocakade of data transfer at port 80 (all internet
> sites report as not responding on both IE and Firefox, exemli gratia) and any
> attempt to establish any kind of socket on that port fails, all that is repaired
> after a restart of the system.
> 
> -Eli Levin
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Browse the site graphics.ru on my computer
> 2.
> 3.
> 
> Actual Results:  
> port 80 is blocked to all traffic
> 
> Expected Results:  
> not block port 80

I have able to sort of reproduce it. It is caused by the installation on the
computer of the .NET framework. The removal of the said framework does resolve
it, and reinstallation cause it again, on several computers that I tried it on.

Updated

13 years ago
Assignee: general → firefox
Component: General → General
Product: Mozilla Application Suite → Firefox
QA Contact: general → general
Version: Trunk → 1.0 Branch

Comment 4

13 years ago
(In reply to comment #3)
> I have able to sort of reproduce it. It is caused by the installation on the
> computer of the .NET framework. The removal of the said framework does resolve
> it, and reinstallation cause it again, on several computers that I tried it on.

So resolving as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > I have able to sort of reproduce it. It is caused by the installation on the
> > computer of the .NET framework. The removal of the said framework does resolve
> > it, and reinstallation cause it again, on several computers that I tried it on.
> 
> So resolving as invalid.
> 
Why did upi resolbe it as invalid? It's a bug related to the presense of .NET
framework on the firefox using computer. Not a minor thing IMHO. The .NET
framework and firefox are still quite rare, but they do spread so you'll see
much more of this bug in the future
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
If something in the .NET framework is causing something to block below the
application level, we can't do much about that, its just the way the network
stacks work.

But at the same time, if we're triggering it somehow, that'd be nice to know.
(Reporter)

Comment 7

13 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > I have able to sort of reproduce it. It is caused by the installation on the
> > > computer of the .NET framework. The removal of the said framework does resolve
> > > it, and reinstallation cause it again, on several computers that I tried
it on.
> > 
> > So resolving as invalid.
> > 
Why did you resolve it as invalid? It's a bug related to the presence of the .NET
framework and firefox on the same Windows system. Not a minor thing IMHO. The
.NET framework and Firefox are still quite rare, but they do spread so you'll see
much more of this bug in the future

PS sorry for all the bad grammar in the previous reply
(Reporter)

Comment 8

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040911 Firefox/0.10.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040911 Firefox/0.10.1
> 
> When browsing many sites, which I couldn't really classify, but have noticed to
> be mainly forums, port 80 is blocked on the computer until restart. All other
> ports work, the said sites do not cause any problems with explorer and are
> generally perfectly good and legitimate sites such as www.graphics.ru. After the
> occurance of the but the reinstall of network card drivers, physical reconnect
> fails to repair a complete blocakade of data transfer at port 80 (all internet
> sites report as not responding on both IE and Firefox, exemli gratia) and any
> attempt to establish any kind of socket on that port fails, all that is repaired
> after a restart of the system.
> 
> -Eli Levin
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Browse the site graphics.ru on my computer
> 2.
> 3.
> 
> Actual Results:  
> port 80 is blocked to all traffic
> 
> Expected Results:  
> not block port 80

(In reply to comment #6)
> If something in the .NET framework is causing something to block below the
> application level, we can't do much about that, its just the way the network
> stacks work.
> 
> But at the same time, if we're triggering it somehow, that'd be nice to know.


I have not debugged it actually, just reproduced the bug and that too by chance
when a friend of mine has installed .NET and reported that he has the same bug
as me with Frefox. Therefor I do not know which side causes the bug. I would
gladly help you debug this if someone could point me in a possible direction. I
am an experienced programmer and gladly offer my help if any of you will contact
me and give me a lead.

Comment 9

13 years ago
WFM

Potentially the reporter can have some program/firewall/malware running that
requires .NET which is responsiblie for this. When .NET is uninstalled it no
longer works and hence problem disappears.

Additional:
I have had .NET and firefox on a number of systems (20+) but have never
witnesses this.
(Reporter)

Comment 10

13 years ago
(In reply to comment #9)
> WFM
> 
> Potentially the reporter can have some program/firewall/malware running that
> requires .NET which is responsiblie for this. When .NET is uninstalled it no
> longer works and hence problem disappears.
> 
> Additional:
> I have had .NET and firefox on a number of systems (20+) but have never
> witnesses this.
> 

I would like to add that it is the developer version of .NET (Visual Studio
2003) and I can assure you that neither me nor the friend which tested this as
well, have malware. We're both experienced programmers and well acquainted in
the ways of computer security.

Comment 11

13 years ago
(In reply to comment #10)
> (In reply to comment #9)
> > WFM
> > 
> > Potentially the reporter can have some program/firewall/malware running that
> > requires .NET which is responsiblie for this. When .NET is uninstalled it no
> > longer works and hence problem disappears.
> > 
> > Additional:
> > I have had .NET and firefox on a number of systems (20+) but have never
> > witnesses this.
> > 
> 
> I would like to add that it is the developer version of .NET (Visual Studio
> 2003) and I can assure you that neither me nor the friend which tested this as
> well, have malware. We're both experienced programmers and well acquainted in
> the ways of computer security.

WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050802 Firefox/1.0+

I have VS.NET 2003 and .NET framework 1.1 on this machine and have never
witnessed it. If you still have this problem, can you please try the latest
nightly build of FF? And please paste here what you see when you type 'netstat'
in the command prompt of Windows as it shows what application connects to port 80.

--> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID

Comment 12

13 years ago
'netstat -a' or 'netstat -ab' may be useful, too.
You need to log in before you can comment on or make changes to this bug.