dpreview.com - The Flash plugin draws on top of an active javascript popup menu (needs wmode="transparent")

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
14 years ago
3 years ago

People

(Reporter: Jeff Craighead, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041018 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041018 Firefox/1.0

The Flash plugin draws on top of an active javascript popup menu on the left if
the menu extends far enough down.  For example the "Forums" popup menu at
http://www.dpreview.com.  Hovering over this menu header results in part of the
menu being covered by the Flash ad.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.dpreview.com (you must have the Flash plugin installed)
2. Select (hover over) "Forums" on the menu at left side of the screen.
3. Notice that the Flash ad below the menu covers part of the popup submenu.

Actual Results:  
Flash draws on top of the javascript popup.

Expected Results:  
The popup should draw on top of Flash so that the sub menu is not obscured.

Comment 1

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20041018 Firefox/1.0
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20041018 Firefox/1.0
> 
> The Flash plugin draws on top of an active javascript popup menu on the left if
> the menu extends far enough down.  For example the "Forums" popup menu at
> http://www.dpreview.com.  Hovering over this menu header results in part of the
> menu being covered by the Flash ad.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Go to http://www.dpreview.com (you must have the Flash plugin installed)
> 2. Select (hover over) "Forums" on the menu at left side of the screen.
> 3. Notice that the Flash ad below the menu covers part of the popup submenu.
> 
> Actual Results:  
> Flash draws on top of the javascript popup.
> 
> Expected Results:  
> The popup should draw on top of Flash so that the sub menu is not obscured.


Same thing happens with http://www.di.fm/

Comment 2

14 years ago
Same with www.spiegel.de. Some pages that have flash adverts in them hide the
javascript pop-up menu (hover over "Ressort wählen" on the left) as in
http://www.spiegel.de/wirtschaft/0,1518,335288,00.html

Comment 3

14 years ago
Strang thing is the first site doesn't do this for me, and the second and third
don't show any flash ads close enought to the popup menus.  BUT, www.asus.com
has this problem to the point the website is almost useless.  I don't know if
this is a Firefox/Mozilla bug, or if the developers of these sits aren't using
CSS to set the correct z-order on these elements.
The wmode="transparent" attribute is needed for this to work in Mozilla. See bug
93959.
Assignee: firefox → english-us
Component: General → English US
OS: Windows XP → All
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Hardware: PC → All
Summary: The Flash plugin draws on top of an active javascript popup menu. → dpreview.com - The Flash plugin draws on top of an active javascript popup menu (needs wmode="transparent")
Resolving as WFM since the site seems to have added that attribute now. Reopen
if you still see issues.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.