After uninstalling Adblock (using extension's built-in uninstaller) Extensions Manager won't open

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
14 years ago
10 years ago

People

(Reporter: ray, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Hi,
 
FireFox 1.0PR under XP PRO is working great!
except for 1 thing lately...
 
The FIREFOX 1.0PR - Extensions Manager does not show up anymore...
(from Tools/Extensions at the top of FF). 
It used to work just fine...showing all installed extensions.
 
In Bugzilla I found the error listed as #  261233,
but I saw no suggested workaround/solution listed there.
 


 


Reproducible: Always
Steps to Reproduce:
Here are the steps to a possible clue:
1)  I had installed the "EXT2ABC" extension from the Mozilla site 5 days ago.
 
2)  It installed OK in FF and I was able to sort alphabetically the entries
     in the Extensions Manager (it added a [SORT] button to it).
 
But...
3)  The display and vertical scrolling of installed extensions in the Extensions
Manager was slow as molasses after installing the "EXT2ABC" extension...
 
So, after a few days of putting up with this unbearably slow scolling display... 
 
4)  I UNinstalled the "EXT2ABC" extension using the "Extension UNinstaller",
(itself an extension from the Mozilla site). 
The UNinstall of the "EXT2ABC" extension seemed to go OK.
 
IT WAS AT THAT POINT IT WENT KAPUT:
5)   I then went to  Tools/Extensions at the top of FF, 
and clicked on the "Extensions" entry.
The hourglass appears for a few seconds and...NADA, nothing!
The  Extensions Manager menu does not pop up anymore...never to be seen again.
 

Actual Results:  
Extensions Manager does not pop up anymore...after click on "Tool/Extensions".

Expected Results:  
Show/pop up the installed extensions in the Extensions Manager window!
(the way it used to before).

DELL PC with XP PRO - 1Ghz
All other features of FIREFOX 0.10.1 are working great!
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Comment 1

14 years ago
I think it was a bad/incompatible extension and/or bug in Ext. Manager's
uninstall. Where did you install it from, what version?

Comment 2

14 years ago
*** Bug 261233 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
*** Bug 263419 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
bug 261233 reports similar situation, but without uninstalling anything.
bug 263419 reports breakage after Adblock was uninstalled. It reports that "an
error message came up and said could not remove a file" during uninstallation,
however no details are provided.

BTW (just noticed), Ray, why did you use the uninstaller extension instead of
built-in uninstaller? Have you had any problems with uninstalling before?

Comment 5

14 years ago
*** Bug 265152 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

14 years ago
I used the 3rd party UNinstaller extension,
because the Extension Mgr. window didn't pop-up anymore (this is exactly the BUG
I had and reported here). 
Thus, I would not be able to use the built-in UNinstaller of the Extension Mgr.
window.

I finally re-created my Firefox 1.0PR profile and REinstalled almost all the 3rd
party extensions. Now the Extension Mgr. window pops-up again fine.

SUGGESTION to the developers of the best browser in the Universe:
in the next version, can you add a feature to automagically re-install selected
extensions from a previous profile.

This would make it very easy to reinstall favorite extensions when creating a
new profile - instead of having to remember the names and re-install each
extension again!  
Of course - before the magic - let the user actually *select* the extension to
install automatically...some old extensions might be the cause of problems.
The user does NOT want to install those extensions again.
C'm guys/gals - I KNOW you can add this feature to Firefox!   

Comment 7

14 years ago
>I used the 3rd party UNinstaller extension,
>because the Extension Mgr. window didn't pop-up anymore (this is exactly the BUG
>I had and reported here). 
>Thus, I would not be able to use the built-in UNinstaller of the Extension Mgr.
>window.
Has it stopped working before or after you used the uninstaller ext? Do you have
any ideas what could have caused the malfunction?

(as for your suggestion (1)don't suggest new things/report new bugs in comments
to another bug, (2)there's will be an extension for that, sooner or later, it is
being developed now).
(Reporter)

Comment 8

14 years ago
Hi Nickolay,

At this point, I'm not sure if the "Extensions Mgr" stopped popping-up
before or after the use of that 3rd party extension.
At this point I simply renewed the profile and reinstalled by hand some
extensions. Everything working OK again, so I cannot reproduce the problem anymore.

BUT...
As I mention in a previous post here, I believe that the problem started
after UNinstalling the 3rd party extension called: "EXT2ABC".
This extension was supposed to alpha sort the entries in the "Extensions Mgr"
window. It did actually sort the entries but the scrolling of these entries was
unbearably slooooow.

So, it was at that point that I decide to UNinstall "EXT2ABC".
As soon as I did the UNinstall, the "Extensions Mgr" window never popped-up again.

Therefore, (if I may), I strongly suspect the UNinstall code of the "EXT2ABC"
extension itself.  Hope this helps you!
RAY

Comment 9

14 years ago
(In reply to comment #8)
> Hi Nickolay,
> 
> At this point, I'm not sure if the "Extensions Mgr" stopped popping-up
> before or after the use of that 3rd party extension.
> At this point I simply renewed the profile and reinstalled by hand some
> extensions. Everything working OK again, so I cannot reproduce the problem
anymore.
> 
> BUT...
> As I mention in a previous post here, I believe that the problem started
> after UNinstalling the 3rd party extension called: "EXT2ABC".
> This extension was supposed to alpha sort the entries in the "Extensions Mgr"
> window. It did actually sort the entries but the scrolling of these entries was
> unbearably slooooow.
> 
> So, it was at that point that I decide to UNinstall "EXT2ABC".
> As soon as I did the UNinstall, the "Extensions Mgr" window never popped-up again.
> 
> Therefore, (if I may), I strongly suspect the UNinstall code of the "EXT2ABC"
> extension itself.  Hope this helps you!
> RAY

I believe I also had that extension loaded when I experienced the problem. Un
installing FF and re installing along with deleting all old profile information
fixed the problem and now I do not have that extension loaded. The extension
manager works fine now. 

Phil

Comment 10

14 years ago
What version (0.1 or 0.2) of the extension have you had the problems with? WFM
with 0.2. If you had problems with the latest version I recommend you to report
the problem to ext2abc's author.

I'm leaving the bug open because it is not clear whether the duped reports had
the same problem.
(Reporter)

Comment 11

14 years ago
PHIL -

Same here.
-I had the "EXT2ABC" extension loaded (the latest version at the time 2 weeks
ago). That's when I experienced the problem. 
-As you suggested to me,PHIL, UN-installing FF and re-installing along with
deleting all old profile information fixed the problem and now =I do NOT HAVE
the "EXT2ABC" extension loaded anymore=. 
-The Extension Manager works fine now for me too!.  :-)

RAY

Comment 12

14 years ago
I'm not sure if I can blame that extension or not. I do know I had it loaded at
the time of the problem, and I don't have it loaded now and it works fine. There
are a few other extensions that I had loaded then (2-3 weeks ago) that I don't
have loaded now.

Phil
(In reply to comment #11)
> PHIL -
> 
> Same here.
> -I had the "EXT2ABC" extension loaded (the latest version at the time 2 weeks
> ago). That's when I experienced the problem. 
> -As you suggested to me,PHIL, UN-installing FF and re-installing along with
> deleting all old profile information fixed the problem and now =I do NOT HAVE
> the "EXT2ABC" extension loaded anymore=. 
> -The Extension Manager works fine now for me too!.  :-)
> 
> RAY

Comment 13

14 years ago
happened here too, after uninstalling adblock with the deinstall option inside
the plugin.

Comment 14

14 years ago
(In reply to comment #13)
> happened here too, after uninstalling adblock with the deinstall option inside
> the plugin.

I experienced the same as Ben Goodger.

Comment 15

14 years ago
I think that AdBlock's built-in uninstaller is not working correctly with
current version of Firefox, please report this issue to its devs.

Updated

14 years ago
Summary: Extensions Manager does not pop up anymore...after click on "Tool/Extensions" → after uninstalling an extension Extensions Manager won't open

Comment 16

14 years ago
(In reply to comment #15)
> I think that AdBlock's built-in uninstaller is not working correctly with
> current version of Firefox, please report this issue to its devs.

I have also had this problem just now (unsolved for days) and needed to 
uninstall *and* delete all profile information after attempting to 'deinstall 
AdBlocker'. 
Basically AdBlocker's deinstall completely kills FireFox's Extension feature. My 
symptoms were the same, no 'Extension Manager' showing.

Comment 17

14 years ago
Okay, I'm making this bug about problems with Adblock uninstaller and resolving
it as invalid, as it's a problem with extension's uninstaller, not with Firefox.

If anybody can reproduce the bug without using uninstaller that comes with an
extension (i.e. not Firefox Extension Manager uninstall function), please file
separate bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Summary: after uninstalling an extension Extensions Manager won't open → After uninstalling Adblock (using extension's built-in uninstaller) Extensions Manager won't open

Comment 18

14 years ago
*** Bug 282297 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
*** Bug 284304 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
*** Bug 287043 has been marked as a duplicate of this bug. ***
*** Bug 291885 has been marked as a duplicate of this bug. ***
*** Bug 311567 has been marked as a duplicate of this bug. ***
*** Bug 299096 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.