If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Should use try/catch to see if reveal is supported

RESOLVED DUPLICATE of bug 472001

Status

SeaMonkey
Download & File Handling
--
minor
RESOLVED DUPLICATE of bug 472001
13 years ago
5 years ago

People

(Reporter: neil@parkwaycc.co.uk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
The download manager (and download progress dialog) currently uses a platform
test to guess whether nsILocalFile.reveal is supported. Instead it should use
try/catch and if the reveal fails it can fall back to opening a browser
directory listing. It also means that should a future Unix port implement reveal
then it will automatically get used. See also attachment 162154 [details] [diff] [review] (FireFox).
Product: Browser → Seamonkey
Hello Neil. Any idea if this old bug is still valid, and if it is, who (or among whom) would be the man (well, the "person") to fix it?
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Hello Neil. Any idea if this old bug is still valid, and if it is, who (or
> among whom) would be the man (well, the "person") to fix it?
Code to implement .reveal for Linux was added to nsILocalFile in the 1.9 timeframe so any new download manager should use .reveal on all platforms.

Comment 3

8 years ago
As comment #2 states, this should be solved with the new download manager introduced by bug 472001
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 472001
You need to log in before you can comment on or make changes to this bug.