Closed Bug 265065 Opened 16 years ago Closed 15 years ago

Preferences-->Appearance-->Startup field doesn't work

Categories

(SeaMonkey :: Preferences, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 58523

People

(Reporter: eagle.lu, Unassigned)

Details

Attachments

(1 file)

1. launch mozilla
2. select Edit->Preferences... menu item
   A prefernce window will popup
3. select Appearance item on the left panel
4. Check "Mail&Newsgroups" checkbox on the right panel and
   Uncheck "Navigator" checkbox
5. quit
6. start mozilla by using the following command:
   mozilla -UILocale en-US -contentLocale US

expect result:
  Mozilla mail client will be launched

actual result:
  Mozilla navigator window is launch. I.e. the previous settings doens't work in
this case.

But if you launch mozilla without any commandline arguments. Mail client will be
launched.
Attached patch patch v0Splinter Review
Comment on attachment 162576 [details] [diff] [review]
patch v0

Can you give r? thanks
Attachment #162576 - Flags: review?(alecf)
+  length = sizeof(StartWithComponents)/sizeof(char*);  

NS_ARRAY_LENGTH

this would be a duplicate of bug 58523...
Summary: Perferences-->Appearance-->Startup field doesn't work → Preferences-->Appearance-->Startup field doesn't work
Product: Browser → Seamonkey
Comment on attachment 162576 [details] [diff] [review]
patch v0

this is wrong, it doesn't scale.
Attachment #162576 - Flags: review?(alecf) → review-

*** This bug has been marked as a duplicate of 58523 ***
No longer blocks: 58523
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.