autocomplete popup for disabled or readonly formular input fields

VERIFIED DUPLICATE of bug 256079

Status

()

Firefox
Disability Access
--
major
VERIFIED DUPLICATE of bug 256079
13 years ago
13 years ago

People

(Reporter: Jan Lolling, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

autocomplete popup for disabled or readonly formular input fields appears and
you can fill this inputfield with values from popup.

Reproducible: Always
Steps to Reproduce:
1. create a inputfield (writable) in a form and fill with any values 
2. disable this inputfield or set readonly and reload page
3. manual filling is disabled but choosing from automcomplete popup is possible !

Actual Results:  
at any disabled or readonly inputfields appears an autocomplete popup what skip
over the readonly restriction. Its is critical for enterprise applications !

Expected Results:  
if a inputfield is disabled or readonly, than no autocomplete popup has to appear.
Fixed in nightly builds after 20041001

*** This bug has been marked as a duplicate of 256079 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.