GetOwnerDocument is broken in XUL

RESOLVED DUPLICATE of bug 198533

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 198533
14 years ago
8 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

The problem is that a slotless XUL element not in a document will defer to the
prototype (if there is one) for the nodeinfo.  So GetOwnerDoc() will return the
prototype document, not the actual XUL document.

Now this situation doesn't arise much, currently, since creation of elements off
prototypes always sets mDocument.  But that's a bug in some cases (eg CloneNode()).

So we really need to fix this to allow us to fix bug 53901 (and bug 226620).
See also the slightly related bug 255077.
Fixed by bug 198533, looks like.

smaug, please reopen if I'm wrong?
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Depends on: 198533
Resolution: --- → FIXED

Updated

8 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 198533
You need to log in before you can comment on or make changes to this bug.