mozilla browser crashes on bad formatted url

RESOLVED DUPLICATE of bug 264944

Status

defect
--
critical
RESOLVED DUPLICATE of bug 264944
15 years ago
15 years ago

People

(Reporter: sirhamacker, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

History is the following one. Michael Zalewski started to more feed browsers
used in the market with URLs randomicamente badly formed. Browsers tested had
been: Microsoft InterNet Explorer, Mozilla, Operate, Lynx and Links. Surprising
the only one browser that not crashed it was the IE. So, Michael share the code
of the used tool to generate the URLs, or either, you yourselves he can prove.
In case that it wants to test, they follow some links for URLs that will go
crash on mozilla :

http://lcamtuf.coredump.cx/mangleme/gallery/mozilla_die1.html
http://lcamtuf.coredump.cx/mangleme/gallery/mozilla_die2.html
http://lcamtuf.coredump.cx/mangleme/gallery/mozilla_die3.html

Reproducible: Always
Steps to Reproduce:
http://lcamtuf.coredump.cx/mangleme/gallery/mozilla_die1.html
http://lcamtuf.coredump.cx/mangleme/gallery/mozilla_die2.html
http://lcamtuf.coredump.cx/mangleme/gallery/mozilla_die3.html

Actual Results:  
crash

Expected Results:  
display error message

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 264944 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.