Closed Bug 265113 Opened 16 years ago Closed 16 years ago

infinite loop with malformed meta refresh

Categories

(Core :: DOM: Navigation, defect, minor)

x86
FreeBSD
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 170021

People

(Reporter: regisr, Assigned: darin.moz)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7) Gecko/20040701 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7) Gecko/20040701 Firefox/0.9.1

If there is a directive:
<meta http-equiv="refresh" content=";http:\\">
the browser refreshs continuously the page as if the delay was 0.
(other browsers seem to ignore, I can't be able to find a reference for the
correct result)

Reproducible: Always
Steps to Reproduce:
1.load the page!
2.
3.



Expected Results:  
load one time and stop
-> docshell
Component: Networking: HTTP → Embedding: Docshell
The spec is lacking but there has been some work on this.

*** This bug has been marked as a duplicate of 170021 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.