Get More Extensions/Themes Buttons Inoperative

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: John Liebson, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041019 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041019 Firefox/1.0

Open Extension or Themes Manager, click on "Get More Extensions" or "Get More
Themes," nothing happens.

Reproducible: Always
Steps to Reproduce:
1. As above in "Details."
2.
3.

Actual Results:  
Nothing.

Expected Results:  
Gone to update.mozilla.org

The site itself is active: I entered its URL in URL box, went there with no
problem. Update button in managers works, just not the link for getting more
extensions or themes.

Comment 1

14 years ago
Additional Confirmation: I see this behavior along with a general inability to
make any window pop up (via javascript or target="_new". When I run in safe
mode, these bugs disappear.

I'm guessing that it is an extension issue. I initially installer Firefox 1PR,
and many extensions thought it was version 0.10. When I later reinstalled 1PR
(version is now 1PR), I updated extensions (some with the automatic updater,
some by 'get more extensions').

No idea WHY this is doing this, but you're not alone.

Comment 2

14 years ago
2 workarounds that worked for me:
1) Create a new profile
2) Uninstall and reinstall all extensions (except DOM inspector and web
developer, which came with Firefox) and reinstall them.

Sorry 'bout the double mail, I should have tested this before my earlier post.

(Reporter)

Comment 3

14 years ago
Based on Additional Comments #1 &#2, I experimented and found that if I disabled
Tabbrowser Preferences 0.9.92, the problem I reported was fixed. I reinstalled
that extension and the problem was no longer there.

Problem fixed for me, but perhaps not for others.

Comment 4

14 years ago
If the problem is not reproducible on a clean profile without any extensions,
it's invalid, I guess, - an extension problem.

Comment 5

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041022
Firefox/1.0 (TBP is not installed)

I suppose it indeed was an extension-related problem. Resolving this bug as WFM
as it works for me, John and David.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.