Find toolbar loses content when new tab clicked

VERIFIED DUPLICATE of bug 250429

Status

()

Toolkit
Find Toolbar
VERIFIED DUPLICATE of bug 250429
13 years ago
9 years ago

People

(Reporter: Bernd Wechner, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

The find toolbar does not remember what it was finding when you click a new tab.
This is arguably a feature, and I couldn't find a dupe when searching the
database, but it does make it very hard to look for a certain text on many web
pages on different tabs (something I do a lot).

Try the steps to reproduce below.

If the toolbar is to have a memory specific to each tab there should ideally be
an option to have a global memory instead I think. This could even be checkbox
on the Find toolbar itself.

Reproducible: Always
Steps to Reproduce:
1. search for something in google say
2. open the first 10 hits with CTRL+CLICK (new tabs
3. now go to the firts tab and press CTRL+F (to find text)
4. Type some text (which is not necessarily what you searched for in google)
5. Now click a new tab and try to find the same text


Actual Results:  
You have to enter the find text again

Expected Results:  
Remembered the find text from the previous tab

The severity is of course difficult to decide and I leave it to FireFox gurus to
recast the severity as needed (no doubt you will!)

Comment 1

13 years ago
Blake fixed this a few days ago, but I don't think he gave a bug number. 
2004-10-17 builds were the first with the fix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 250429 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.