HTML-garbage during simple http-requests with server-side mod_gzip activated

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: info, Assigned: darin.moz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7.3) Gecko/20040910

With an empty browser cache or in a 1st visit situation a simple http: request
will result in html-garbage, when the webserver is an apache with mod_gzip
activated.

The error is reproducable (tested) with german versions:
Win2kSP4, WinXP pro SP2, Mac OSX 10.2.x, Linux (Knoppix 3.4)

The error is independend from your hardware performance. Tested with:
G3-400 MHz., PIII 850 MHz., Athlon XP 1.2, Athlon XP 2.6+

The error is independend from your Mozilla software. Tested with german versions:
Mozilla Suite 1.7.1 to 1.7.3, Firefox latest stable release.

The error seems to be independend from your internet connection. Tested with:
(A)DSL768 and (A)DSL3000

You can reproduce the error with any of the OSs above, but not with Win98SE!!!
(* The error does also not occur with MS IE, MSN Explorer, Konqueror, Apple
Safari and Opera. *)

After deactivating the mod_gzip everything works great. Even response times and
page build times seem to be much (!) faster. (* Thanks to the fast 'n' friendly
technical support from schottenhost.de. *)

Reproducible: Always
Steps to Reproduce:
1. Find a (Apache) server with mod_gzip activated for your account.
2. Upload a website with media-rich (text, tables, pictures, layers,...) content
on some webpages.
3. Be sure, that your browser cache is empty! (Clear it, if the error is not
visible for the first time you try to reproduce the error.)
4. Load (1st visit) or reload (after cache is empty) the webpage esp. the
media-rich.
5. If everything seems to be fine, try it again from step 3. on. (2x to 3x fresh
reloads)
6. If the error occurs, hit your reload button and everything looks as it should
look.
7. Beg your webhoster to deactivate the mod_gzip and try step 3. to 5. again for
4x to 5x times.

Actual Results:  
After deactivating mod_gzip everything works fine. (* You can not (!) reproduce
the error with the URL http://www.hgb-praxis.de from above, because mod_gzip was
deactivated. *)  

Expected Results:  
The software should be able to handle mod_gzip delivered webpages. It is to my
opinion not acceptable to obligate any webhosting service, that they should
deactivate mod_gzip in their default setups, because it costs (time, traffic,
space, ...), esp. if all other browsers have no problems.
>  (* You can not (!) reproduce
>the error with the URL http://www.hgb-praxis.de from above, because mod_gzip was
>deactivated. *)  

...
why did you mention the URL at all then.

do you have any url that shows this problem? mozilla supports gzip-compressed
pages... this works for me, for example at http://mozilla.kairo.at/

Alternatively, can you create an HTTP log for a page showing the problem? to do
that, follow the instructions at
http://www.mozilla.org/projects/netlib/http/http-debugging.html . thanks!
Assignee: general → darin
Component: Browser-General → Networking: HTTP
QA Contact: general → core.networking.http
ok,
since this bug can not be reproduced, I'm suspecting it has the same cause as
bug 241085 comment 20, which means it's a server bug. marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.