need option to force parsing of HTML character entities

VERIFIED DUPLICATE of bug 166521

Status

MailNews Core
Internationalization
VERIFIED DUPLICATE of bug 166521
13 years ago
9 years ago

People

(Reporter: Eyal Rozenberg, Assigned: smontagu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Sometimes one receives messages which are supposed to be text but are comprised
of unicode character entities. There should either be an option to parse these,
or to force the message to be displayed as HTML (in which case they will
automatically be parsed).


I have a feeling this bug is dupe but my searches have been fruitless.

Here is an example of such a message (with most headers removed):

Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit

הפגנה -
היום
הבינלאומי

Comment 1

13 years ago
Yeap. If you wan to see how I found it, open the link below and press "Edit this
search"
 https://bugzilla.mozilla.org/buglist.cgi?query_format=&short_desc_type=allwordssubstr&short_desc=&product=MailNews&product=Thunderbird&long_desc_type=allwordssubstr&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&emailtype1=substring&email1=&emailtype2=substring&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=product&type0-0-0=substring&value0-0-0=html&field0-0-1=component&type0-0-1=substring&value0-0-1=html&field0-0-2=short_desc&type0-0-2=substring&value0-0-2=html&field0-0-3=status_whiteboard&type0-0-3=substring&value0-0-3=html&field1-0-0=product&type1-0-0=substring&value1-0-0=entit&field1-0-1=component&type1-0-1=substring&value1-0-1=entit&field1-0-2=short_desc&type1-0-2=substring&value1-0-2=entit&field1-0-3=status_whiteboard&type1-0-3=substring&value1-0-3=entit

Prog.

*** This bug has been marked as a duplicate of 166521 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.