If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox starts up too slowly

VERIFIED DUPLICATE of bug 254627

Status

()

Toolkit
Startup and Profile System
--
enhancement
VERIFIED DUPLICATE of bug 254627
13 years ago
9 years ago

People

(Reporter: Christopher Lee, Assigned: Benjamin Smedberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

It takes Firefox too long to start up

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
reporter: did you experience a firefox crash or a system crash while firefox was
running?  or are you just talking about normal startup times?  i'm asking
because after a crash, firefox does some costly pruning of the disk cache to
ensure system integrity.  that can take a very long time making it seem like
firefox isn't starting up.

Comment 2

13 years ago
I also have problems with long startup times with Firefox 0.9.3 and 1.0PR, on
two computers. My home computer Celeron 1,2 MHz 768 MB (Firefox 0.9.3) and work
computer Pentium IV 2,6 GHz 1 GB (Firefox 1.0PR). On my home computer, with 7
Firefox windows open, it takes 5 to 6 seconds for a new Firefox window to
appear. At my work it also takes several seconds. 

It clearly takes a longer time per window, the more Firefox windows are already
open. If only one window is open, a new window opens in about 2 seconds on my
home computer.

Installed Firefox extensions at my home computer: DOM Inspector 1.0, SwitchProxy
Tool 1.3, Googlebar 0.9.0.28, Download Manager Tweak 0.5.2, ieview 0.83.

I am using Windows XP Professional fully updated (SP2) (home), Windows 2000
fully updated (work).
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
> reporter: did you experience a firefox crash or a system crash while firefox was
> running?  or are you just talking about normal startup times?  i'm asking
> because after a crash, firefox does some costly pruning of the disk cache to
> ensure system integrity.  that can take a very long time making it seem like
> firefox isn't starting up.

normal startup times

Comment 4

13 years ago
Duping to Bug 254627 because of very similar content/comments.

Reporter, if you feels this was done in error, please REOPEN.

*** This bug has been marked as a duplicate of 254627 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.