crash (double caption?) [@ nsCSSFrameConstructor::GetFrameFor]

RESOLVED DUPLICATE of bug 265181

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 265181
15 years ago
15 years ago

People

(Reporter: thomas+mozilla, Assigned: dbaron)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5 (KHTML, like Gecko) Safari/125.9
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041020

I was doing some FireFox QA using iExploder - http://toadstool.se/software/iexploder - and stumbled 
upon this crash bug a few times. I can't make heads or tails of what HTML generates the issue, but in 
both of my test cases, the <caption> tag exists.


Reproducible: Always
Steps to Reproduce:




Talkback crash ID's: TB1431722W, TB143174K
Reporter

Comment 1

15 years ago
Stack trace from this test case:

Thread 0 Crashed:
0   <<00000000>>	0x045f1360 0 + 0x45f1360
1   org.mozilla.firefox 	0x0031c034
nsCSSFrameConstructor::FindPrimaryFrameFor(nsPresContext*, nsFrameManager*,
nsIContent*, nsIFrame**, nsFindFrameHint*) + 0x90
2   org.mozilla.firefox 	0x0034e7f0
nsFrameManager::GetPrimaryFrameFor(nsIContent*) + 0x170
3   org.mozilla.firefox 	0x001fd050
PresShell::GetPrimaryFrameFor(nsIContent*, nsIFrame**) const + 0x1c
4   org.mozilla.firefox 	0x00319d1c
nsCSSFrameConstructor::CharacterDataChanged(nsPresContext*, nsIContent*, int) +
0x44
5   org.mozilla.firefox 	0x001fcb9c
PresShell::CharacterDataChanged(nsIDocument*, nsIContent*, int) + 0x20
6   org.mozilla.firefox 	0x002621bc
nsDocument::CharacterDataChanged(nsIContent*, int) + 0x84
7   org.mozilla.firefox 	0x00479abc
nsGenericDOMDataNode::AppendData(nsAString const&) + 0x164
8   org.mozilla.firefox 	0x0037883c SinkContext::FlushText(int*, int) +
0xe4
9   org.mozilla.firefox 	0x00377b40
SinkContext::CloseContainer(nsHTMLTag) + 0x24
10  org.mozilla.firefox 	0x00145f4c CNavDTD::CloseContainer(nsHTMLTag,
nsHTMLTag, int) + 0x1f0
11  org.mozilla.firefox 	0x00145ff4 CNavDTD::CloseContainersTo(int,
nsHTMLTag, int) + 0x90
12  org.mozilla.firefox 	0x0014126c CNavDTD::DidBuildModel(unsigned,
int, nsIParser*, nsIContentSink*) + 0x10c
13  org.mozilla.firefox 	0x00147dc4 nsParser::DidBuildModel(unsigned) +
0x78
14  org.mozilla.firefox 	0x00148d24 nsParser::ResumeParse(int, int, int)
+ 0x250
15  org.mozilla.firefox 	0x00149ed4 nsParser::OnStopRequest(nsIRequest*,
nsISupports*, unsigned) + 0xa8
16  org.mozilla.firefox 	0x00509544
nsDocumentOpenInfo::OnStopRequest(nsIRequest*, nsISupports*, unsigned) + 0x7c
17  org.mozilla.firefox 	0x000d86ac
nsFileChannel::OnStopRequest(nsIRequest*, nsISupports*, unsigned) + 0x50
18  org.mozilla.firefox 	0x000a304c nsInputStreamPump::OnStateStop() +
0xa0
19  org.mozilla.firefox 	0x000a2bd4
nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) + 0x80
Reporter

Comment 2

15 years ago
Thread 0 Crashed:
0   org.mozilla.firefox 	0x00315f04
nsCSSFrameConstructor::GetFrameFor(nsIPresShell*, nsPresContext*, nsIContent*)
+ 0x3c
1   org.mozilla.firefox 	0x00317608
nsCSSFrameConstructor::ContentAppended(nsPresContext*, nsIContent*, int) + 0xf8

2   org.mozilla.firefox 	0x001fcc88
PresShell::ContentAppended(nsIDocument*, nsIContent*, int) + 0x2c
3   org.mozilla.firefox 	0x002622f4
nsDocument::ContentAppended(nsIContent*, int) + 0x74
4   org.mozilla.firefox 	0x0037c800
HTMLContentSink::NotifyAppend(nsIContent*, unsigned) + 0x34
5   org.mozilla.firefox 	0x00377c70
SinkContext::CloseContainer(nsHTMLTag) + 0x154
6   org.mozilla.firefox 	0x00145f4c CNavDTD::CloseContainer(nsHTMLTag,
nsHTMLTag, int) + 0x1f0
7   org.mozilla.firefox 	0x00145ff4 CNavDTD::CloseContainersTo(int,
nsHTMLTag, int) + 0x90
8   org.mozilla.firefox 	0x0014126c CNavDTD::DidBuildModel(unsigned,
int, nsIParser*, nsIContentSink*) + 0x10c
9   org.mozilla.firefox 	0x00147dc4 nsParser::DidBuildModel(unsigned) +
0x78
10  org.mozilla.firefox 	0x00148d24 nsParser::ResumeParse(int, int, int)
+ 0x250
11  org.mozilla.firefox 	0x00149ed4 nsParser::OnStopRequest(nsIRequest*,
nsISupports*, unsigned) + 0xa8
12  org.mozilla.firefox 	0x00509544
nsDocumentOpenInfo::OnStopRequest(nsIRequest*, nsISupports*, unsigned) + 0x7c
13  org.mozilla.firefox 	0x000d86ac
nsFileChannel::OnStopRequest(nsIRequest*, nsISupports*, unsigned) + 0x50
14  org.mozilla.firefox 	0x000a304c nsInputStreamPump::OnStateStop() +
0xa0
15  org.mozilla.firefox 	0x000a2bd4
nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) + 0x80
16  libxpcom.dylib		0x0707ff64 0x7000000 + 0x7ff64
17  libxpcom.dylib		0x07040fa4 PL_HandleEvent + 0x24
18  libxpcom.dylib		0x07040ec8 PL_ProcessPendingEvents + 0x80
19  libxpcom.dylib		0x070413ac PL_IsQueueNative + 0x88
20  com.apple.HIToolbox 	0x927d1fc8 DispatchEventToHandlers + 0x150
Reporter

Comment 3

15 years ago
I'm beginning to suspect the bug source is actually double captions. I've built some more test cases 
with double captions that have completely different back traces. 
Summary: nsCSSFrameConstructor::GetFrameFor crash in nightly builds of Mozilla & FireFox → nsCSSFrameConstructor::GetFrameFor crash (double caption?)
There's a good chance this is a duplicate of bug 265181 
Depends on: 265181

Updated

15 years ago
Assignee: general → dbaron
Component: Browser-General → Style System (CSS)
QA Contact: general → ian
Summary: nsCSSFrameConstructor::GetFrameFor crash (double caption?) → crash (double caption?) [@ nsCSSFrameConstructor::GetFrameFor]

Comment 6

15 years ago
both testcases cont crash with the patch in bug 265181
So this is a duplicate, right?

Comment 8

15 years ago
I believe so, the patch is in , so tomorrows builds should have it

*** This bug has been marked as a duplicate of 265181 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Blocks: iexploder
You need to log in before you can comment on or make changes to this bug.