Inline forwarded messages won't be wrapped whereas replied will

RESOLVED DUPLICATE of bug 249093

Status

RESOLVED DUPLICATE of bug 249093
14 years ago
11 years ago

People

(Reporter: peter, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5 (KHTML, like Gecko) Safari/125.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.7.3) Gecko/20040910

When an html message with long non-wrapped lines (Apple Mail creates these for an example) and the 
user chooses to forward this message in-line Composer won't wrap the lines but leave them as they are 
while reply would wrap them. 
This wouldn't be a problem if you don't want to print them: When printing such a forwarded mail you 
would get a printout with a very small font because mozilla wants to squeeze all the text on a page-
width. 
Furthermore printing of the original mail does _not_ fail, it is printed correctly.

Reproducible: Always
Steps to Reproduce:
1. Send an html e-mail to yourself containing very long, non-wrapped line (>100 chars per line)
2. Forward it 
3. Print the forwarded message
Actual Results:  
When printing such a forwarded mail you would get a printout with a very small font because mozilla 
wants to squeeze all the text on a page-width. 

Expected Results:  
The lines should be wrapped as they are in a reply

Comment 1

14 years ago
Is the mail account that you're forwarding from configured for HTML or plain 
text compose?

When the original HTML message is displayed, does it show the "long lines" *as* 
long, unwrapped lines (e.g. inside a <pre> block), or do you have the original 
HTML message displayed "as plain"?  Or does it wrap the text on display?  If the 
latter, I am unable to duplicate the problem, whether composing in plain text or 
in HTML.

See bug 237558.
Product: MailNews → Core

Comment 2

14 years ago
No response from reporter; duping.

*** This bug has been marked as a duplicate of 249093 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.