Browser fails to display an HTML file, when I double-click on it

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: mark.lehky, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927

I have found, what I suspect to be, a bug. Unfortunately, I am not enough of an
engineer/hacker/man to be able to determine where exactly the problem lies -
hence I filed it in the general category. Further, I tried to find it using
BugZilla search, but I could not, possibly due to the fact that I am not sure
where the bug exactly fits. Appologies if this is a duplicate.

I have browsed to the samples category in "C:\Program
Files\mozilla.org\Mozilla\res\samples", and double clicked on one of the samples
just to see what would happen. I only got the initial Mozilla splash screen, and
then nothing.
When I opened the sample in Notepad, it has a problem with the CR/LF pairs,
similar to what happens when one transfers a .txt file from a UNIX machine to a
Windows machine using a binary file mode!

Reproducible: Always
Steps to Reproduce:
I have tried the following things:

Case 1.
1. Open Mozilla.
2. Open one of the samples using File -> Open File.
3. No problem, the file displays correctly.

Case 2.
1. Using Windows Explorer, "explore" over to the samples directory.
2. Double-click on one of the files.
alternate2. Right-click on one of the files, and select Open With -> Mozilla.
This produces the same result...
3. Only the Mozilla splash-screen appears, and then nothing ...


Expected Results:  
I expected the file to be displayed. Since HTML is supposed to be CR/LF
independant, I think this may be a bug.
If I am correct, and this is indeed a bug, I would really like to see this as a
"major" category. Again, I appologize if this is a false alarm.

I suspect this may be related to (my) bug
https://bugzilla.mozilla.org/show_bug.cgi?id=262988 since the two show the same
symptoms.

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)
-I/usr/X11R6/include

Configure arguments
--without-system-jpg --without-system-zlib --enable-extensions=default,tasks
--enable-crypto --disable-auto-deps --disable-debug --enable-optimize

Comment 1

14 years ago
works for me with recent seamonkey 1.8a5 and firefox builds on winxp sp2 when
they are associated with opening html files when double clicking the test0.html
file when the browser is not already open and when the browser is opened. What
settings do you have for the preference in Edit->Preferences->Advanced->System
for HTML documents?

Do you have the environment variable MOZ_REMOTE set? That causes a new Mozilla
process to be loaded instead of using a new one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

14 years ago
I checked the preferences, and turned on the HTML documents. Same results.

I do not understand the last sentence: "That causes a new Mozilla
process to be loaded instead of using a new one." The word 'new' appears twice,
is that correct? For whatever it's worth, I do not have the vaible set.

I do not believe this error is caused by some setting. It looks like Mozilla
parses the HTML incorrectly, when the CR/LF pairs are missing from the source -
only those "squares" show up. Any other "correct" HTML files, which have all the
CR/LF as is normal under Windows, open just fine. Is this possible?

I will check this again when Alpha5 comes out. It might be just something that
creeped into Alpha4. On that other bug that I mentioned - 262988 - someone told
me that Alpha3 does not exhibit the problem.
(Reporter)

Comment 3

14 years ago
I have just tried the same thing with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041021
the problem is still there! Therefore there might be a problem with my explanation.

Here are the exact steps that I (just now) took:
1. Grab the full installer from "Latest Builds". Install only the browser.
2. Completely exit out of Mozilla. Please note that I turned OFF the "quick
start" feature.
3. Using Windows Explorer, go to "C:/Program
Files/mozilla.org/Mozilla/res/samples/".
4. Right-click on test0.html, and select "Open With -> Mozilla".
5. Only the splash-screen appears, and then nothing. This is incorrect, the file
should be displayed.

Other notes:
- When I open the same file with Notepad, it shows "mangled" characters where
newlines should be. This is what normally happens when one transfers a txt file
from a UNIX system to a Windows system, using a binary mode of transfer.
- When I open the same file with I-Explorer, it displays correctly.
- When I open the same file in Mozilla, using "File -> Open File" method, it
also displays correctly.
- When I have Mozilla started, and then follow the above procedure from step 3,
 the Mozilla windows is brought into the foreground, but the file fails to display.

What else can I offer you, in order to reproduce the bug?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

14 years ago
I don't know what else is needed to reproduce the bug. It still works for me.

My build is Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041021
Under the system prefs I have all filetypes and protocols checked.

One thing is to look at how the registry is set for Mozilla to open files.

1. open windows explorer
2. click tools, then folder options
3. click filetypes
4. scroll down to HTML, click HTML then click Advanced
5. click open then edit

What does it say in the "Application used to perform action" text box?
Is "use DDE" checked?
What is in the DDE, Application, and Topic?


(Reporter)

Comment 5

14 years ago
I had left all the defaults that were set by the application:

Action = &Open
Application used = "C:\Program
Files\mozilla.org\Mozilla\mozilla.exe" %1
Use DDE = on
DDE Message = ""
Application = mozilla
DDE application not running = ""
Topic = System
(Reporter)

Comment 6

14 years ago
Is there anything else that I can do, to get this bug at least to confirmed?

Comment 7

14 years ago
Mark, I have been thinking about this and the best bet I can come up with is to
go on IRC on the moznet (irc.mozilla.org) and join #mozillazine to ask for help
in reproducing the bug. You may be able to find someone else who can reproduce
it or find someone who understands the difference in your environment that
causes the problem.
Product: Browser → Seamonkey
(Reporter)

Comment 8

14 years ago
I just tried this on a completely different computer:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041122
and there is not problem. The main diff between the two is WinXP (problem) vs.
Win2k (no problem). So something on my XP machines is set up wrong / different -
it's the machine where I work, and they have ridiculous amounts of stupid
security policies.
So I take this bug back. Sorry for all the wasted time. :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.