reloading a page with POSTed form data will result in incorrectly "checked" radio buttons

VERIFIED DUPLICATE of bug 46845

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 46845
13 years ago
13 years ago

People

(Reporter: Steve Hinesley, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I have an exam engine written in PERL which creates randomized exams where the
answers are selected via radio buttons. On the initial load, the page renders as
expected. If I reload the page, some of the radio buttons are not "checked"
correctly after resending the POSTed data. Viewing the page source, however,
confirms that the item that should be "checked" is not. I.e., the HTML shows the
correct information, but the page is rendered incorrectly. On the incorrectly
selected items it appears to check the position of the previously selected
answer prior to reload. If I save the output of the CGI as an HTML file and load
it directly into Firefox, it renders as expected. Neither Internet Explorer nor
Konquerer exhibit this behavior. I have not tested if the GET method also
performs this way.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




I may be able to provide access to a sample exam, but a signed non-disclosure
agreement would be necessary.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

13 years ago
Works perfect now!!!
You need to log in before you can comment on or make changes to this bug.