bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Creating new account crashes MailNews client



MailNews: Account Configuration
18 years ago
14 years ago


(Reporter: lduperval, Assigned: J Shane Culpepper)


Firefox Tracking Flags

(Not tracked)




18 years ago
Build ID: 1999122808
HPUX-11 version of M13

I created a new account and answered all the questions. After clicking the
Finish button, mozilla crashed:

/usr/lib/dld.sl: Unresolved symbol:
__ath_AppendElement__11nsMsgFolderFP11nsISupports_24__FP11nsISupports (unknown)
from /usr/local/mozilla/libmsgbaseutil.sl

Comment 1

18 years ago
is there ANY chance you can get me the demangled name of that function?


Comment 2

18 years ago
Uh... no? The binary I have is the one from ftp.mozilla.org. If you have a

procedure for me to follow to unmangle (using GNU tools only) the proc name, I

can try it. Otherwise, I'm SOL.

Comment 3

18 years ago
Heh, I just tried c++filt on linux and I got this:
__ath_AppendElement__11nsMsgFolderFP11nsISupports_24(nsISupports *)

which makes me think that this is just nsMsgFolder::AppendElement, but that is
defined so I don't know why it would barf like that.

can you see if c++filt gives you anything different on HP? 
sometimes there's a demangle() call... on solaris, there's something called
cplus_demangle(const char *symbol, char *prototype, size_t size);

If this exists on HP, you could try this:
int main(int argc, char *argv[]) {
  char buf[100];
  cplus_demangle(argc[1], buf, 100);
  printf("demangled: %s\n", buf);

This may end up being a waste of time though, because nsMsgFolder::AppendElement
seems like the only possible match, and it IS defined

I'm adding Jim Dunn because he's done some work on HP

Comment 4

18 years ago
Alec if it is ok with you we (haha shane!) will 'take this bug' 

Assignee: alecf → pepper

Comment 5

18 years ago
gee... you're offering to take work off my plate and fix this? I guess I can
live with that :)

Comment 6

18 years ago
I am trying to reproduce this now but can't seem to.
Without giving me all of your specific info can you 
go through the data you entered.

-email address (was this vaild?)


-mail server (just the hostname or fully qualified hostname.domain?)
-outgoing mail server (hostname or fully qualified?)

-username (did you change this? or go with default?)
-password (did you check the box and enter a valid password?)

-account name (did you modify this?)

I don't see the problem here... how old is your 11.00 OS?


Comment 7

18 years ago
Uhgg.  I'll start looking into this as soon as I have a free second or two.  
Could you tell us what type of machine you're running on.  We currently build on 
64 bit Workstations.  Are you running on 11.00 Server or Workstation.  It might 
help us reproduce the bug.  I have a debug build of M13 thankfully but I'll need 
to reproduce it before I can do anything useful.
Target Milestone: M14

Comment 8

18 years ago
OK, Let's try to do this b4 the next meeting.uname -a yields

HP-UX mg1c4l B.11.00 A 9000/712 2002413113 two-user license

I don't know the name of my HPUX but the latest Y2K (what a joke) patches were

applied in December. Since mine is a 32 bit machine, it may be running in

emulation model. I don't really know how HPUX 11 works.

Now, let me do a step-by-step until it crashes and give you the lowdown:

- Press the Mail button

- New Messenger Account Wizard pops up

- Select Mail | Next

- Enter my name (Laurent Duperval)

- Enter my email address (laurent.duperval@cgi.ca). This is an address that is

rewritten on our mail server since I log on as another id on my HPUX server.

-Select IMAP. Enter fully qualified host name for IMAP and SMTP servers. The

names are different (may be this is a reported bug: Mozilla won't post to our

server which requires authentication).

- Click Next

- Enter user id on server. This is different from my workstation's login ID and

from my email adress. Don't touch Password Storage

- Account Name: Leave as is (contains my email address)

- Click Next then Finish

- Get fire extinguisher to put out flames from crash:

/usr/lib/dld.sl: Unresolved symbol:

__ath_AppendElement__11nsMsgFolderFP11nsISupports_24__FP11nsISupports (unknown)

from /usr/local/mozilla/libmsgbaseutil.sl


Comment 9

18 years ago
I've tried various things to reproduce this without success.  Are you running 
the script mozilla to initialize and do you have your SHLIB_PATH set to include 
/usr/lib?  I'll try this on a 32bit 11.00 machine if I can find one around here 
to test on.  Did you remove componet.reg from the install directory and remove 
$(HOME)/.mozilla.  If you used a previous version of mozilla the registry may be 
screwed up.  Just some things to try.

Comment 10

18 years ago
changing QA contact to the reporter: laurent.duperval@cgi.ca since this is on 
HPUX and my group is not testing on that platform.
QA Contact: lchiang → laurent.duperval

Comment 11

18 years ago
Well, my machine has been reconfigured and 10.20 has been installed. I think
that the bug should be closed.

Comment 12

18 years ago
Closing (per Laurent's request) this as 'works for me' based on what 
we were able to see (or weren't in this case).
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 13

18 years ago
mark verified to really close out this bug report.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.