If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

domain is overwritten (autocompleted) with default domain

VERIFIED FIXED in Thunderbird0.9

Status

Thunderbird
Message Compose Window
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: Brian Ryner (not reading), Assigned: Scott MacGregor)

Tracking

unspecified
Thunderbird0.9
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
It's possible for the domain you type for a receipient to be overwritten with
the default domain (i.e. user.com, if you are joe@user.com).

Steps to reproduce:

1. Open a message compose window
2. Type just the user part of an email address that's not in your address book
and is not at the same domain as your email address.
3. Wait for thunderbird to autocomplete the domain.
4. Type "@someotherdomain.com", overwritten the domain that was autocompleted
5. Hit tab

Result:

The domain in the recipient field has reverted back to the default domain!
(Reporter)

Comment 1

13 years ago
requesting blocking1.0, this seems pretty bad, could result in sending mail to
the wrong person without even realizing it
Flags: blocking-aviary1.0?
(Assignee)

Comment 2

13 years ago
i don't understand your description brian. That sounds like the correct
behavior. We always append the default domain if you don't provide one.

Can you post a screen shot maybe?
(Reporter)

Comment 3

13 years ago
I think you're missing step #4.  Thunderbird has provided the autocompletion for
the domain, but I typed over it with a different domain.  Then when I hit tab,
it reverts to what it had autocompleted instead of what I typed.

Note, to reproduce this it seems to be necessary to hit tab immediately after
you finish typing the domain (my guess is, before the autocomplete timer would
fire).  If you wait a second or so after typing the domain, then hit tab, it
stays.  It seems like the autocomplete is firing even though focus is no longer
in the recipient field.
(Assignee)

Comment 4

13 years ago
as soon as you type an @ sign we kill autocomplete and won't attempt to append a
default domain or auto complete that row.

I can't reproduce this on windows because of that fact. Once the @ sign is typed
the line is dead and it doesn't matter how fast I tab out of the autocomplete
row....
(Reporter)

Comment 5

13 years ago
You have to have let it autocomplete once while entering the address, _then_
finish it and quickly tab out.
(Reporter)

Comment 6

13 years ago
Btw, I'm seeing this on windows nightly 20041021.

Comment 7

13 years ago
*** Bug 261819 has been marked as a duplicate of this bug. ***

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All
Summary: domain is overwritten with default domain → domain is overwritten (autocompleted) with default domain

Comment 8

13 years ago
Other bugs related to keystrokes too fast to process in the address fields: 
bug 163103, bug 261272, bug 264957
(Assignee)

Comment 9

13 years ago
this was a regression from my attempt to fix Bug #244522.

I just checked in a better fix for 244522 which doesn't cause this regression. 

Marking this as fixed now.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird0.9
(Assignee)

Comment 10

13 years ago
*** Bug 267325 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
Bug 278398 - address typed gets replaced with first email address from dropdown
list after Tab is pressed. Similar?
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.