text-align (CSS) does not work in inputs (HTML) of type submit

RESOLVED DUPLICATE of bug 138403

Status

()

--
minor
RESOLVED DUPLICATE of bug 138403
14 years ago
14 years ago

People

(Reporter: thomas.krause, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

As see you see in http://www.informatik.hu-berlin.de/~krause/ff-bug.html, the
CSS-attribute "text-align" is ignored at input-tags of the type "submit".
Firefox always renders this with the text centered. Other browsers (IE, Opera)
do not ignore this attribute.

Reproducible: Always
Steps to Reproduce:
1. load http://www.informatik.hu-berlin.de/~krause/ff-bug.html


Actual Results:  
text in the buttons is not rendered like wished

Expected Results:  
proper rendering

I also made a screenshot:
http://www.informatik.hu-berlin.de/~krause/ff-bug_before.png

The bug has been already discussed under
http://forums.mozillazine.org/viewtopic.php?t=136125&highlight=input+textalign,
but i didn't find a bugreport in BugZilla.

There is a workaround that works fine for me, but maybe should be included in
the distribution:
1. in the file res/forms.css search for the follwing:

*|*::-moz-button-content {
  display: block;
  text-align: center;
}

2. comment "text-align:center" out

*|*::-moz-button-content {
  display: block;
 /* text-align: center; */
}

3. Now all text in buttons is left-justified by default (which can be overrriden
by the websites)- that's not that god either. So go to the folder holding the
user profile (I'm using unfortunally the German version of WinXP and I'm not
sure how it's called in other language versions, so that's the path I'm using:
C:\Dokumente und
Einstellungen\USER\Anwendungsdaten\Mozilla\Firefox\Profiles\default.sa2\chrome)
and edit the file "userContent.css". If there isn't a file named like this make
a new one.

4. In "userContent.css" add the following line:

button, input[type="reset"], input[type="button"], input[type="submit"]
{text-align:center}

5. after saving the file restart Firefox and the test-page should look like in
this screenshot:

htpp://www.informatik.hu-berlin.de/~krause/ff-bug_after.png
(Reporter)

Comment 1

14 years ago
Created attachment 162992 [details]
the html-file
(Reporter)

Comment 2

14 years ago
Created attachment 162993 [details]
what's looking like
(Reporter)

Comment 3

14 years ago
Created attachment 162994 [details]
what it should look like
So I guess the solution would be to move text-align:center out of
*|*::-moz-button-content and into
input[type="reset"],input[type="button"],input[type="submit"] in forms.css. 

*** This bug has been marked as a duplicate of 138403 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.