Last Comment Bug 265610 - Scrolling content below a transparant GIF is really cpu intensive
: Scrolling content below a transparant GIF is really cpu intensive
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 6 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.geneesmiddelenrepertorium....
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 05:40 PDT by Ger Teunis
Modified: 2011-11-22 06:28 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Excellent example of bug 284986 (20.59 KB, image/png)
2005-03-07 04:49 PST, Jasper Lieber
no flags Details
New testcase, previous not working anymore (11.00 KB, text/html)
2006-08-02 07:55 PDT, Ger Teunis
no flags Details

Description Ger Teunis 2004-10-22 05:40:35 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041021 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041021 Firefox/1.0

Scrolling content behind a transparant GIF is a real slowdown.
My AthlonXP 3200+ with a Geforce5200 has around 90% CPU load.
Performed a testcase with the same site and a transparant PNG> much faster and
acceptable scrolling speeds!


Reproducible: Always
Steps to Reproduce:
1. Go to above mentioned URL
2. Scroll vertically
3.

Actual Results:  
Real slow scrolling and a high CPU load.

Expected Results:  
normal page scrolling speed.
Comment 1 Peter van der Woude [:Peter6] 2004-10-29 08:24:03 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041029
Firefox/1.0RC1

->WFM
Comment 2 Ger Teunis 2004-12-16 15:22:33 PST
Noticably slow are the scrolls when clicking on the arrows of the verical
scrollbar (and visible on high resolutions).
Comment 3 Peter van der Woude [:Peter6] 2005-01-06 06:54:33 PST
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20050106
Firefox/1.0+

Confirming

I didn't have the problem before because I used 16-bit color i/o 32-bit
It makes a huge difference in performace for me (32-it a lot worse)
Comment 4 Steve England [:stevee] 2005-01-18 07:12:05 PST
Actually to me it seems that the scrolling content behind the transparant GIF
scrolls at the speed it should do; it's the rest of the page outside the GIF
that is lagging whilst scrolling.
Comment 5 Ger Teunis 2005-03-04 05:57:57 PST
Updated the URL (previous URL disappeared)
Comment 6 Jasper Lieber 2005-03-04 23:38:51 PST
(In reply to comment #3)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20050106
> Firefox/1.0+
> 
> Confirming
> 
> I didn't have the problem before because I used 16-bit color i/o 32-bit
> It makes a huge difference in performace for me (32-it a lot worse)

This bug may be related to bug 201198.

And checking 201198 with various driver / monitor depths is an excellent idea! 
I'll try it....
Comment 7 Jasper Lieber 2005-03-07 04:49:20 PST
Created attachment 176565 [details]
Excellent example of bug 284986

Sorry to be slightly off topic, but the URL for this bug turns out to be the
best example of bug 284986 I've seen yet.  I'd bet they're related.
Comment 8 Jasper Lieber 2005-03-07 05:00:37 PST
Could this bug be related to  Bug 64401, Extremely slow performance with png
background??
Comment 9 ArronM (:paper) 2005-03-09 18:57:32 PST
There's been some progress on transparent GIF speeds recently, and it may have
effected this bug.

Reporter, can you try this with a latest nightly?
Comment 10 Ger Teunis 2005-03-09 23:18:05 PST
(In reply to comment #9)
> There's been some progress on transparent GIF speeds recently, and it may have
> effected this bug.
> 
> Reporter, can you try this with a latest nightly?

It is fixed here, no more high CPU load during scroll.

But I'm still seeing the problem described in comment#4: content in the
transparant gif 'box' is painted before the rest of the content. But that
problem may not be in the scope of this bug?
Comment 11 Steve England [:stevee] 2005-03-10 09:03:02 PST
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050310
Firefox/1.0+
Scrolling up and down quickly with smoothscroll enabled and an MS Intellimouse 4
I can get my CPU usage up to 83%, but at all times scrolling is fast and
responsive. Win2ksp4, axp2400, nvidia gf4ti4400 (71.84), 32bit colour, 1152x864
Comment 12 Ger Teunis 2006-08-02 07:55:24 PDT
Created attachment 231749 [details]
New testcase, previous not working anymore
Comment 13 RNicoletto 2010-10-20 09:13:29 PDT
This is WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Comment 14 Virtual_ManPL [:Virtual] - (ni? me) 2011-11-21 13:21:00 PST
can be marked as dupe of bug #595671
Comment 15 RNicoletto 2011-11-22 06:28:33 PST
FIXED as per comment 13 and comment 14.

Note You need to log in before you can comment on or make changes to this bug.