Flash animation *kills* Mozilla's navigation (arrows, spacebar)

VERIFIED DUPLICATE of bug 78414

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 78414
14 years ago
14 years ago

People

(Reporter: Eric Lecht, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040803

This one may be time-sensitive to prove; SF Gate's real cool "panimation" Flash
presentation of the SF skyline and how it likely will change is there today,
unknown whether it'll be there tomorrow (likely...).

I crack SF Gate's homepage, see a special on SF's changing skyline. I go to
special page, run animations...

I run the Java animation in a tab. I run another Java "drive-thru" across Bay
Bridge in another browser window, the one elucidating changes to SF's skyline
from Loma Prieta project.

In all OTHER non-Flash tabs now, spacebar and arrow keys cease to work. 

Kill the animation windows, functionality restores.

I took a few minutes to scroll thru some other bugs; not all 10,000 however.
Forgive me if this were covered, and I didn't recognize it (descriptions can be
obtuse, or rather I simply don't have the programming background to understand...).

There you have it. I tried it a few times....

Eric

Reproducible: Always
Steps to Reproduce:
1.Run Flash animation in a tab, then run subsequent animation(s) both in tab and
other window (I recall)
2.Click on Flash animations/run Java applet
3.Go back to non-Flash tab
Actual Results:  
Could not navigate w/ arrow keys, nor spacebar (i'm trying as we speak, w/
animation running). Clicking and dragging slider worked, as did slider arrows
(i'm doing it as we speak).

Expected Results:  
Tab window navigation functions (arrows/spacebar) as expected?

Comment 1

14 years ago
If the Flash animating somehow managed to keep the focus (despite that yous
elected another tab), it's bug 78414 
(Reporter)

Comment 2

14 years ago
That seems to be what's happening. Just tried it; what 78414 says and what
happens here jibe. This makes sense. I'll read the rest of 78414 and see what's
up...

Thanks for pointing this out.....

regards,

Eric Lecht 

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 78414 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.