Losing window.opener - property when opening a window cascade

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: CMIndividual, Unassigned)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.1) Gecko/20040707

see Steps to Reproduce

Reproducible: Always
Steps to Reproduce:
1. in Window (URL1) : window.open(URL2)
2. in Window (URL2) : window.open(URL3)

Actual Results:  
Window (URL2) loses its opener-Reference to Window (URL1)

Expected Results:
Dan, did you get that opener fix in yet?

/be
Assignee: general → general
Component: JavaScript Engine → DOM: Level 0
QA Contact: pschwartau → general

Comment 2

14 years ago
My window.opener adjustment recently checked in for bug 263844 applies only to
tabbed windows in Firefox Aviary. This bug report was filed against Mozilla
1.7.1 20040707.

My interpretation of the rather terse steps to reproduce is that a window's
opener property is cleared upon opening another window. Luckily I had lying
around a testcase suitable to substitute for the testcase missing from this bug
report. I can't reproduce the bug in either a recent Firefox build or a Mozilla
1.8a2 build I happen to have.
Reporter, please attach a testcase showing the problem (using
https://bugzilla.mozilla.org/attachment.cgi?bugid=265733&action=enter)

Comment 4

14 years ago
I have a testcase where I fetch a variable in a grandparent window from the
child window with opener.opener.VariableName and it works as expected in Mozilla
1.8b build 2005011505 and Firefox 1.0 build 20041107 (XP Pro SP2 here). Since we
got no reply from the reporter for a long time and since Dan can't reproduce the
bug, I am

resolving as WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.