Crash when opening http://www.linux-magazin.de/ [@ NewOrRecycledNode]

RESOLVED DUPLICATE of bug 272286

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 272286
14 years ago
7 years ago

People

(Reporter: Felix Wiemann, Unassigned)

Tracking

({crash})

1.7 Branch
x86
Linux
crash
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041017 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041017 Firefox/0.10.1

Firefox crashes when opening the page http://www.linux-magazin.de/.

Reproducible: Always
Steps to Reproduce:
1. Start Firefox.
2. Open http://www.linux-magazin.de/.
3. Wait while the page is loading.

Actual Results:  
Firefox terminates with the following message:
./run-mozilla.sh: line 451:  3197 Segmentation fault      "$prog" ${1+"$@"}
(Reporter)

Comment 1

14 years ago
This only occurs if JavaScript is enabled.

Comment 2

14 years ago
Could you please provide Talkback IDs?
(Reporter)

Comment 3

14 years ago
Incident ID: TB1513750Y

Updated

14 years ago
Assignee: firefox → general
Component: General → JavaScript Engine
Keywords: crash
Product: Firefox → Browser
QA Contact: firefox.general → pschwartau
Summary: Crash when opening http://www.linux-magazin.de/ → Crash when opening http://www.linux-magazin.de/ [@ NewOrRecycledNode]
Whiteboard: DUPEME
Version: unspecified → 1.7 Branch
NewOrRecycledNode() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsparse.c,
line 169]
NewParseNode() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsparse.c,
line 217]
Statement() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsparse.c,
line 1950]
Statements() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsparse.c,
line 1233]
js_CompileTokenStream() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsparse.c,
line 452]
CompileTokenStream() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsapi.c,
line 3111]
JS_CompileUCScriptForPrincipals() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsapi.c,
line 3194]
JS_EvaluateUCScriptForPrincipals() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/js/src/jsapi.c,
line 3644]
nsJSContext::EvaluateString() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 141]
nsScriptLoader::EvaluateScript() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 668]
nsScriptLoader::ProcessRequest() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 582]
nsScriptLoader::OnStreamComplete() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 905]
nsStreamLoader::OnStopRequest() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsStreamLoader.cpp,
line 606]
nsStreamListenerTee::OnStopRequest() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsStreamListenerTee.cpp,
line 66]
nsHttpChannel::OnStopRequest() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp,
line 606]
nsInputStreamPump::OnStateStop() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsInputStreamPump.cpp,
line 606]
nsInputStreamPump::OnInputStreamReady() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/netwerk/base/src/nsInputStreamPump.cpp,
line 339]
nsInputStreamReadyEvent::EventHandler()
PL_HandleEvent() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 674]
PL_ProcessPendingEvents() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/plevent.c,
line 608]
nsEventQueueImpl::ProcessPendingEvents() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/xpcom/threads/nsEventQueue.cpp,
line 395]
event_processor_callback() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 67]
libglib-2.0.so.0 + 0x4513d (0x4058d13d)
libglib-2.0.so.0 + 0x25405 (0x4056d405)
libglib-2.0.so.0 + 0x23828 (0x4056b828)
libglib-2.0.so.0 + 0x2589b (0x4056d89b)
libglib-2.0.so.0 + 0x23e0f (0x4056be0f)
libgtk-x11-2.0.so.0 + 0xd1e0f (0x40290e0f)
nsAppShell::Run() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 144]
nsAppShellService::Run() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
xre_main() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 692]
main() 
[/builds/tinderbox/firefox-0.10.1/Linux_2.4.20-28.8_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 59]
Flags: blocking-aviary1.0?

Comment 5

14 years ago
no fix. too late.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Severity: normal → critical

Comment 6

13 years ago
-> default qa
QA Contact: pschwartau → general

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 272286 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Crash Signature: [@ NewOrRecycledNode]
You need to log in before you can comment on or make changes to this bug.