Browser crash when I open several links & then close them in a specific sequence

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: dovix, Assigned: Blake Ross)

Tracking

({crash})

1.0 Branch
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040212 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1

opening a certain sequence of links and then closing them causes the browser to
crash.

Reproducible: Always
Steps to Reproduce:
One time setup:

1. Create in your bookmarks toolbar a new folder "crash"
2. Add to that folder the following sites:
- http://www.hebdolinux.org/
- http://www.varlinux.org/vl/html/modules/stories/
- http://www.varlinux.org/vl/html/modules/stories/redirect.php?storyid=6565
- http://www.varlinux.org/vl/html/modules/stories/redirect.php?storyid=6561

To crash the browser:

3. Open all links in tabs
4. Now use the "X" to close tabs
5. When you close the "FT" link, the browser will crash


Actual Results:  
Firefox will crash

Expected Results:  
Firefox shouldn't crash

I am using the build from Mozilla's site.

The following error shows on the command line:

./firefox/run-mozilla.sh: line 451: 22529 Segmentation fault      "$prog" ${1+"$@"}
Warning: Cannot convert string "-adobe-helvetica-medium-r-*-12-*" to type FontStruct
Warning: Cannot convert string "-adobe-helvetica-bold-r-*-12-*" to type FontStruct

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041022
Firefox/0.10.1 (MOOX M3)

XP  SP2


same problem
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041023 Firefox/1.0

I opened just the second link in a tab and closed it with [X]:Crash

->NEW
OS->ALL
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Version: unspecified → 1.0 Branch

Updated

13 years ago
Keywords: crash
(Reporter)

Comment 3

13 years ago
Created attachment 163134 [details]
The HTML page that causes the crash

Attached is the HTML page that apparently is the cause of the crash.

The test case can be performed as follows:

1. Open Firefox
2. Open file & load the HTML
3. Close the browser
4. The "feedback agent" will start to signal a crash

Same effect can be created by opening the file in a separate tab, then closing
the tab.
(Reporter)

Comment 4

13 years ago
Even simpler to run testcase:

1. Open the link above "The HTML page that causes the crash" in a separate tab.
2. Change to the new tab and close it with 'X'
3. Firefox will crash

Comment 5

13 years ago
unable to reproduce this with the latest windows XP branch build or the latest
linux branch build. 
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> unable to reproduce this with the latest windows XP branch build or the latest
linux branch build. 

The 2004-10-25 Branch build does seem to solve the problem. I also re-tested
with 1.0PR to double check it still crashes and so it did...

So I guess one of the latest fixes you guys did took care of that.

Thanks!

Comment 7

13 years ago
Testcase worksforme using latest Firefox 1.0 RC1 release: Mozilla/5.0 (Windows;
U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

Marking worksforme based on everyone's recent comments.  If we find out which
bug fix might have fixed this one, please update the bug.  Or if anyone is able
to reproduce with a recent nightly after 10/16, please reopen.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.