Link in Bookmarks Toolbar to Automounted SMB File Causes Very Long Startup Delay If SMB Mount Not Available

RESOLVED DUPLICATE of bug 273198

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 273198
14 years ago
13 years ago

People

(Reporter: John Desmond, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (compatible; MSIE 6.0; Windows NT 5.1) http://www.bigtubresort.ca
Build Identifier: Mozilla/5.0 (compatible; MSIE 6.0; Windows NT 5.1)   [Firefox 1.0PR]

I installed firefox-1.0PR-i686-linux-gtk2+xft-installer.tar.gz on my Red Hat 9
system, upgrading from 0.8.
My wife's Windows laptop has a directory that I access with an automounted
smbmount. Any attempt to access the directory causes automount to kick off.
Today I noticed that Firefox took almost a minute to load. I traced it to
several links to files in the Windows share.
Whenever Firefox loads, or if those links are moved within the bookmark
structure, automount kick off. This results in a small (about 1 sec.) delay on load.
Unfortunately, if the laptop is off the delay is on the order of a minute and
the desktop can't be used. Only the clock is moving.
I moved back to 0.8 to verify that automount doesn't kick off on load or when
those bookmarks are twiddled.
The workaround is to place those automount links in a subdirectory of Personal
Toolbar Folder (Bookmarks Toolbar).

Reproducible: Always
Steps to Reproduce:
1. Assuming you have an automount file system set up, drag a link to a file in
that system from the URL bar to the bookmark bar.
2. Make the file system unavailable.
3. Close and reopen Firefox. Watch /var/log/messages to see automount messages.
Firefox will seem to hang for a minute or so.

Actual Results:  
Firefox startup delays until a timeout occurs. Automount has many failed retries.

Expected Results:  
As with 0.8, Firefox should open immediately without 'exercising' the bookmarks.

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → toolbars

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 273198 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.