Last Comment Bug 265802 - Improve printing options
: Improve printing options
Status: RESOLVED DUPLICATE of bug 35228
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows 98
: -- enhancement with 1 vote (vote)
: ---
Assigned To: Blake Ross
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-23 17:26 PDT by kosta_kp
Modified: 2010-01-17 17:59 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description kosta_kp 2004-10-23 17:26:31 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Firefox should give you the ability, as in most other programs, to:
1. Choose custom print ranges (ex. Page(s): "5,6,8-10").
2. Choose to print only even/odd pages.

Also, consider:
3. "Print selection" on the right-click context menu.
4. Show a print preview of your specific selection or page range, not
necessarily the whole webpage.
5. Manual duplex (double-sided) printing, as in MS Office XP and later.

Reproducible: Didn't try
Steps to Reproduce:
N/A
Actual Results:  
N/A

Expected Results:  
N/A
Comment 1 Walter Lindell 2004-12-23 17:04:51 PST
Is this the only bug that addresses the inability of Mozilla to print odd/even
pages?
Comment 2 William Bumgarner [:zsinj] 2005-04-04 06:24:09 PDT

*** This bug has been marked as a duplicate of 35228 ***
Comment 3 RDL 2010-01-17 17:59:21 PST
This is not a duplicate of 35228 as that officially only addresses request 2 (print only odd/even pages). There is a comment lower down in 35228 suggesting it should be extended to include custom print ranges as here described but the title does not reflect that. If anything, perhaps 35228 is a part duplicate of this bug.

Please either reopen this bug (and mark 35228 as a dup of it?)or change the title of 35228 to include

request 1 (Choose custom print ranges (ex. Page(s): "5,6,8-10").

Note that the Windows native print dialogue, used in default by Firefox does include the option to print selected pages but that is never shown by Firefox.

Note You need to log in before you can comment on or make changes to this bug.