Support SVGElementInstance event delivery for <svg:use>

RESOLVED WONTFIX

Status

()

Core
SVG
RESOLVED WONTFIX
13 years ago
a year ago

People

(Reporter: tor, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.9.2a1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
 
(Reporter)

Updated

13 years ago
Depends on: 237020

Updated

8 years ago
Blocks: 485172

Comment 1

8 years ago
Created attachment 369293 [details]
all three rectangles should raise an alert when clicked

if a better testcase is available please attach.

parity Opera

Updated

8 years ago
Target Milestone: --- → mozilla1.9.2a1
Assignee: general → nobody
QA Contact: ian → general

Updated

8 years ago
Duplicate of this bug: 513579

Comment 3

7 years ago
I don't see any onmouseclick attributes on some of those SVG elements. Why are they still supposed to fire events still?

Comment 4

7 years ago
The testcase uses addEventListener instead of an onmouseclick attribute. It's just two different ways of doing the same thing.

Comment 5

7 years ago
Sigh, my bad. Can't wrap my mind around it. Must be the heat.
Blocks: 508561
Blocks: 595840

Comment 6

6 years ago
Created attachment 518946 [details]
Test cases for addEventListener bug

As I bumped into this bug myself yesterday, I spent some time building a series of simple test cases to demonstrate the bug more precisely and show what works and what doesn't in Firefox.

Clicking on any square in the test-case file should produce an alert dialog box.

All of the test cases pass in Opera 11, Safari 5, and Chrome 10.  I have not tested it in IE9.

However, while Firefox correctly handles clicks on the ten green squares, it fails on clicks on the four red squares in both Firefox 3.6 and in Firefox 4.0 RC1.

Updated

4 years ago
Duplicate of this bug: 957313
Keywords: dev-doc-needed
SVGElementInstance trees have been removed from SVG 2, so we won't be doing this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.