the websites menu displays incorrectly

RESOLVED INVALID

Status

()

Firefox
Build Config
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: tony palmer, Assigned: Brian Ryner (not reading))

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

instead of being limited to a specified table size, the div based menu expands
to the full size of the page, i can make it any size i want but is still in
proportion to the whole page. the menu is made for IE mainly, but works in opera
6 and 7, and displays in firefox (wheras it does not in mozilla) which led me
tobelive it was a firefox bug as opposed to bad coding (i have played with the
code and understand what is happening, but it would seem like a rather large
flaw in an otherwise fine page rendering engine.

other less complicaed div's like align="right" also display outside of thier tables.

Reproducible: Always
Steps to Reproduce:
1.visit http://greencanteen.co.uk/sk/home.html
2.hover over the menu items (one, two, three, four, five)
3.the popup should be 20% of the table the menu is in

Actual Results:  
the menu spans the current width of the page (from it's set origin), adding that
to the overall page width

Expected Results:  
displayed the div as 100% of the table cell it is contained in, and not 100% of
the whole page

this is the only website i have seen the problem on, i made it myself and feel
quite confident that i know what is happening in the code. understandably,
browsers are differnt, but with the cahnge from no support in mozilla to this
limited support, i imagined it was still a work in progress.

Comment 1

14 years ago
Created attachment 163263 [details]
testcase

You have an absolutely positioned element with a width of 100%.  Since it's
absolutely positioned, it is not constrained by the 20% width of the
surrounding DIV.

See http://www.w3.org/TR/CSS21/visudet.html#containing-block-details

This rendering is correct.  Bug is invalid.

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Keywords: testcase
Resolution: --- → INVALID
rescued from the mailbox that catches our bounces:

Date: Mon, 25 Oct 2004 10:27:35 +0100                                          
                                                    
From: Tony Palmer <phischfood@gmx.net>                                         
                                                    
To: bugzilla-daemon@mozilla.org                                                
                                                    
Subject: Re: [Bug 265905] the websites menu displays incorrectly               
                                                    
                                                                               
                                                    
i don't know if i can reply to this, but i will anyway. you reached the        
                                                    
same conclusions as i did initially. although i do not understand why (on      
                                                    
another page which i did not seem relevant enough to also specify              
                                                    
http://greencanteen.co.uk/sk/profiles.html where an non absolute DIV pushes    
                                                    
text outside of it's containing cell.                                          
                                                    
the absolute position would seem to be rendered correctly in firefox,  but     
                                                    
the dramatic change in 2 already well grounded browsers would make me still    
                                                    
suggest otherwise, especially when no support was previously offered (the      
                                                    
pops didn't even work in firefox0.9)                                           
                                                    
sorry to bother you with this                                                  
                                                    
yours warmingly                                                                
                                                    
                 tony                                                          
                                                    
You need to log in before you can comment on or make changes to this bug.