nsIObserverService::removeObserver fails at browser.js::Shutdown

VERIFIED DUPLICATE of bug 283116

Status

()

VERIFIED DUPLICATE of bug 283116
14 years ago
14 years ago

People

(Reporter: jruderman, Assigned: bugzilla)

Tracking

({memory-leak})

1.0 Branch
x86
Windows XP
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
I've been seeing this error a lot:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://browser/content/browser.js :: Shutdown :: line 832"  data: no]

Line 832 is

os.removeObserver(gBrowser.browsers[0], "browser:purge-session-history");

More removeObserver lines follow, which I think means this could cause memory leaks.

I'm using a build between 10/22 and 10/23.  I'm using the following extensions:
Thumbs, Search Keys, Favicon Picker, Delicious Delicacies, MILTON Integration.
The exception is being thrown by this line:

  os.removeObserver(gBrowser.browsers[0], "browser:purge-session-history");

Strangely enough, the first few lines in the Shutdown function are the only ones
that don't have a try catch around them.  Looks like they should.

I've got a surefire way of getting this exception.

Steps:

1. Create a new profile (to rule out extensions)
2. Start Firefox (window will open).
3. Open javascript console
4. Open new tab.
5. Right click on newly created tab and click close other tabs.
6. Click the close tabs button when the prompt comes up.
7. Close browser window
8. Look in javascript console for error which always occurs either on step #6 or
#7 above.
Forgot this was filed

*** This bug has been marked as a duplicate of 283116 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Flags: blocking-aviary1.1?
(And I really should have fixed this for 1.0; too bad I didn't notice the
bugmail at the time...)
You need to log in before you can comment on or make changes to this bug.