installer should include search plugin options

VERIFIED WONTFIX

Status

()

Firefox
Installer
--
enhancement
VERIFIED WONTFIX
13 years ago
12 years ago

People

(Reporter: Craig Kovatch, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I think the Firefox installer should include checkboxes for which of the default
search plugins you would like installed - for example, I'd like to be able to
turn off Amazon and Yahoo when I am installing.

Reproducible: Always
Steps to Reproduce:

Comment 1

13 years ago
This adds too much complex UI to the Firefox custom installer. We want to keep
things simple and comprehensible. Too many people will think that unchecking
these options will mean that they won't be able to browse Yahoo! and Amazon, and
too many people will think that installing these search plugins will install
some kind of advertising toolbar.

I'm marking this as WONTFIX, because it complicates the installer way too much.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

13 years ago
How does this add any UI at all? The installer already has checkboxes for the
DOM inspector and quality feedback agent, both which lack any real explanation
at all anyway. It would be very simple to add checkboxes for these plugins along
with a description at the bottom. Neither would require any UI additions.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 3

13 years ago
As a user who moved from IE, I _really_ want this custom install option so that
I can turn off search options I don't want/need (e.g. Creative Commons?). It'll
be better once 284625 is addressed, sure, but it's still an annoyance when
setting FF up on my relative's computers. Give me a Typical, Custom, even a
Minimal (no themes or search bar stuff except Google). PS - Mr.Ebrahim, we're
not all idiots - give the users some credit, or at least respect.
This isn't something we're going to do. Sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WONTFIX

Comment 5

13 years ago
verify wontfix per comment 1
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.