Closed Bug 265934 Opened 16 years ago Closed 15 years ago

Clicking 'Desktop' in Download Manager shows wrong folder

Categories

(Firefox :: Shell Integration, defect, P2)

x86
Windows XP
defect

Tracking

()

VERIFIED FIXED
Firefox1.5

People

(Reporter: harmhilvers, Assigned: torisugari)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041024 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041024 Firefox/1.0

If you go to the Download Manager, there is a button with 'Desktop' on it (I
haven't edited my setting, this is thus standard behaviour). Click it and it
shows me my Desktop folder in Windows Explorer. Well, that's what I expected. It
shows me a folder with this address: "C:\DOCUMENTS AND SETTINGS\HARM\BUREAUBLAD"
(I'm using a Dutch Windows XP version). But this isn't my Desktop folder. Using
Microsoft's Powertoys I set my Desktop folder to "D:\Bureaublad". That's also
the place where Firefox's downloads go to and that works like a charm. But when
I clicked the 'Desktop' button in the DM I expected to see my own Desktop folder
and not the old one.

Reproducible: Always
Steps to Reproduce:
1. Tools > Options... > Downloads > Set 'Save all downloads to this folder' to
'Desktop' (one of the options in the dropdownbox)
2. Go to the Download Manager
3. Click 'Desktop'

Actual Results:  
There opens an incorrect folder when you have changed the standard Desktop
folder in Windows with Microsoft's Powertoys.

Expected Results:  
Firefox should have opened the correct folder, i.e. it should have opened
"D:\Bureaublad" instead of "C:\DOCUMENTS AND SETTINGS\HARM\BUREAUBLAD".

This topic on MozillaZine forums holds some discussion about this bug:
http://forums.mozillazine.org/viewtopic.php?t=149941
It's been there a long time. Confirming with Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.7.3) Gecko/20041022 Firefox/1.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Harm, which values are set within the registry? Take a look at
SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Shell Folders\\Desktop
for HKCU and HKLM.

The code for retrieving the desktop folder you can see here:
http://lxr.mozilla.org/aviarybranch/source/browser/installer/windows/browser.jst#69
(In reply to comment #2)
> Harm, which values are set within the registry? Take a look at
> SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Shell Folders\\Desktop
> for HKCU and HKLM.

The value for Desktop in HKCU is: "D:\Bureaublad"
HKLM does not have that value set in the register. There is one with the name
"Common Desktop" and it's value is "C:\Documents and Settings\All
Users\Bureaublad". But that is not the folder the 'Desktop' button in the
Download Manager show me.

It looks like Firefox uses the default Desktop folder (the folder Windows also
uses if you don't change it with f.e. Powertoys) when you click the button in
the Download Manager. But I don't have any idea where Firefox gets that value from.
This was bug 228977, but that was fixed in June. This should be in your build of
Firefox.
Apparently this bug is not fixed by the fixes for #228977, otherwise I should
not be seeing this bug even in the lateste nightly's. ;)

Is there someone who can point me to some of the involved code? Comment #2 does
so. But it seems to me, but I am not sure about that, that the code mentioned
there is about the installer and not about the download manager. Is that correct
or am I wrong?
Attached patch PatchSplinter Review
Per comment #5

This was left out of bug 228977 and its patch 
attachment 148884 [details] [diff] [review] for some reason.
Attachment #169422 - Flags: review?(mconnor)
Comment on attachment 169422 [details] [diff] [review]
Patch

hrm, odd, I could have sworn lxr had three results when I reviewed the other
patch.
Attachment #169422 - Flags: review?(mconnor) → review+
(In reply to comment #8)
Thanks the review.
mconnor, will you check this in to the tree,
when you are not very busy?
I'm quite sure you have cvs write access.
Whiteboard: checkin-needed
Flags: blocking-aviary1.1?
*** Bug 279971 has been marked as a duplicate of this bug. ***
*** Bug 280150 has been marked as a duplicate of this bug. ***
*** Bug 266984 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.1? → blocking-aviary1.1+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050313
Firefox/1.0+

Downloaded today with a Fresh Install. New because reformatted system. When
setting the preferance in Options V Menu, it shows ask where, but will only
download the file to the desktop. I tried this without any extensions and it did
it, added dl tweak 6.5 and now two Download Windows open and if you close one
then the download stops. 
Flags: blocking-aviary1.1+
Jen,

Don't remove the blocking flag by Ben. 
He set it to blocking and leave it that way.

Jeremy
Flags: blocking-aviary1.1+
forgotten bug ?
cc-> mconnor (no one else seems to be able to check this on in Mike ;-))
Assignee: bugs → torisugari
Priority: -- → P2
QA Contact: os-integration → gavin.sharp
Target Milestone: --- → Firefox1.1
Version: unspecified → Trunk
Whiteboard: checkin-needed → [checkin needed]
Checking in downloads.js;
/cvsroot/mozilla/toolkit/mozapps/downloads/content/downloads.js,v  <--  downloads.js
new revision: 1.42; previous revision: 1.41
done
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
And now it works fine! :) Thanks to all who worked on this.
Status: RESOLVED → VERIFIED
QA Contact: gavin.sharp
You need to log in before you can comment on or make changes to this bug.