Crash at starting (Firefox 1.0PR)

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Robert Richter, Assigned: Blake Ross)

Tracking

({crash})

1.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; MyIE2; SV1; .NET CLR 1.1.4322)
Build Identifier: Firefox 1.0PR

crash window when I starting firefox:

                 accesskey="&allowPopups.accesskey;"
----------------------------^

Reproducible: Always
Steps to Reproduce:
1. install Firefox 1.0PRE
2. starting Firefox from the question in the installer -> crash
3. starting Firefox from the Desktop-Icon -> crash
4. starting Firefox from the mini-Icon in the starting-border -> crash
(Reporter)

Updated

14 years ago
Version: unspecified → 1.0 Branch

Updated

14 years ago
Severity: normal → critical
Keywords: crash
Summary: crash at starting (Firefox 1.0PR) → Crash at starting (Firefox 1.0PR)
Can you give us a talkback id of that crash?
(Reporter)

Comment 2

14 years ago
I received no further informations to this error, except this window.:
http://www.richterrobert.de/mozfire.png
And after you closed this window Firefox crashes immediately? Or is it just
closed? When the crash occurs please look inside the program directory for
'components\talkback.exe' and enable the quality feedback agent. When the crash
happens again send a talkback and give us the id. 

Please also try it with a fresh profile. How old is your existing one?
(Reporter)

Comment 4

14 years ago
talkback.exe output before and after the crash:
0 incidents to send (with a new profile)
0 incidents to send (with the old (2 days) profile)
What do you mean by Firefox crashes? Is talkback enabled and do you get the
quality feedback agent? If not, how does Firefox crash? Please descibe exactly
or add a screenshot. When a real crash occurs talkback should catch it.
(Reporter)

Comment 6

14 years ago
ONLY the window http://www.richterrobert.de/mozfire.png comes after the start
from firefox. Now I downgrade to 0.9.3. ;-(

Comment 7

14 years ago
Hello,

I have (nearly) the same thing on MacOS X with the latest build (Id est release
Candidate) in german. I took this one:

http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.0rc1/Firefox%20(1.0rc1,%20de-DE).dmg.gz

On double click the browser starts up, show the Firefox Menu and a window with
light yellow background color and red text:

label="&bidiSwitchTextDirectionItem.label;"
-------^
accesskey="&allowPopups.accesskey;"
-----------^

The window can be closed and the app does not actually crash, but has to be shut
down explicitly from this state.

I am quite sure that my profile is rather old and taken with me since many
releases and yes, this will probably be the reason for misbehaviour. However I
will stick with the version as of September 14th because I actually want to keep
my profile forever and dont want to reimport bookmarks, passwords and so on
again. I dont understand why this works sometimes but not always.

Also, the bugs I filed so far are not on the list of fixed bugs in the release
notes, so I am not that eager to test the latest build to overcome this problem.

Thanks for developing Firefox anyway, Christian

Comment 8

14 years ago
I can confirm this on Windows 2000 when upgrading from 1.0PR English to 1.0
German. When upgrading to 1.0 English all works fine.

Proposal for new summary:
 browser does not start, dialog with accesskey="&allowPopups.accesskey;

Comment 9

14 years ago
I have heard from two users of the swedish version getting the yellow dialog box
posted above. One of them tried the english version instead, and it worked fine.

Comment 10

14 years ago
Hello,

when the final version came out, I really wanted to solve this issue with my
profile not working with the current versions of Firefox. This is how I solved
the issue for me: 
Rename the ~/Library/Application\ Support/Firefox folder.
Start up the fresh copy. It will create a fresh profile.
Copy several files from the old profile to the new bundle.
Copy the searchplugins folder from the application bundle to the new versions
Application bundle.
Start up the browser again.

The files I copied over are as follows. 
No folders. This means obviously the Cache(.Trash) folders but also chrome and
extension folders. Chrome especially seems closely related to my issues as the
browser stopped starting when I copied them over as well. the Extensions were
not properly uninstalled so I decide to install them again separately to avoid
to carry with me the problems caused by some of them.

No .ini-files. I had got the feeling that they are out of order for now.
bookmarks.html, cookies and (form)history.dat should be selfexplaining and usual.
XUL.mfasl and xpti.dat seemed too dangerous to me. xpti.dat probably has
something to do with the extensions installed while XUL is prbably closely
related to the chrome folder.

I took over all .db files which seem to contain sensible Data I was not willing
to search for manually in real world and reentering these figures. Here is a
listing of my profile folder, including the action to be taken:

-rw-------    8025  66054866.s        copy
drwxr-xr-x    2006  Cache/            
drwxr-xr-x      68  Cache.Trash/      
-rw-r--r--  948302  XUL.mfasl         
-rw-r--r--  326502  bookmarks.bak     
-rw-r--r--  326502  bookmarks.html    copy
-rw-------   65536  cert8.db          copy
drwxr-xr-x     238  chrome/           
drwxr-xr-x     272  chrome_x/         
-rw-r--r--      65  compatibility.ini 
-rw-r--r--       0  components.ini    
-rw-r--r--  140179  compreg.dat       
-rw-r--r--     438  cookies.txt       
-rw-r--r--     180  defaults.ini      
-rw-r--r--     338  downloads.rdf     
drwxr-xr-x     442  extensions/       
-rw-r--r--  127331  formhistory.dat   copy
-rw-r--r--  424621  history.dat       copy
-rw-r--r--    1333  hostperm.1        copy
-rw-------   16384  key3.db           copy
-rw-r--r--   30230  localstore.rdf    
-rw-r--r--   17585  mimeTypes.rdf     
-rw-r--r--    1325  panels.rdf        candidate
-rw-r-----       1  popupcount.dat    
-rw-r--r--    8309  prefs.js          copy
-rw-r--r--     752  search.rdf        
-rw-------   16384  secmod.db         copy
-rw-r--r--   81084  xpti.dat          

As of now I am perfectly happy with the result.
Firefox is booting up, has bookmarks and saved
password available.

Still I think there should be a profile test
or repair Utility in a future release. The
least option ist to import old profiles in
the profile Manager.

äyours, Christian
Marking WFM cause it shouldn't happen anymore with current Firefox 1.0.x releases.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.