Wrong number of downloads shown

VERIFIED DUPLICATE of bug 245829

Status

()

Toolkit
Downloads API
--
trivial
VERIFIED DUPLICATE of bug 245829
14 years ago
10 years ago

People

(Reporter: Mikael Hedberg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
The build I'm using is a nightly build from the aviary-l10n nightlies
(Mozilla/5.0 (Windows; U; Windows NT 5.0; sv-SE; rv:1.7.3) Gecko/20041022
Firefox/1.0)

After downloading a lot of files (~100) in one go, with around 20 different
downloads active at any one time for quite a while, and after a recent crash
while downloads were active, the count of the number of files is no longer
correct (it shows 6 'ghost' files), as well as a percentage which is incorrect.

This screenshot shows the issue:
http://www.mozilla.se/bugs/firefox-dlbug.png

The window is from the sv-SE l10n version, but the problem should be apparent
from the title of the window (7 files) when only one download remains. The "all
downloads finished" info box still pops up correctly when the last download
finishes, and the title of the Download manager correctly reverts to only
"Filhämtaren" (Download manager).

However, starting another download brings back the number 7:
http://www.mozilla.se/bugs/firefox-dlbug2.png

There are no .part files left, so all downloads appear to have finished
successfully.
(Reporter)

Comment 1

14 years ago
Addition: The problem goes away when Firefox is restarted.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 245829 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.