Closed Bug 265958 Opened 18 years ago Closed 18 years ago

if an url is passed composed of two "http://" parts, www.microsoft.com homepage is shown!

Categories

(Firefox :: General, defect)

1.0 Branch
x86
Linux
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 231720

People

(Reporter: stegalli, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040928 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040928 Firefox/0.9.3

if an url is passed composed of two "http://" parts, www.microsoft.com homepage
is shown!
for example try http://http://www.debian.org or
http://http://www.whatever-you-want-to-try.com
If you search "http" in google, microsoft homepage is indeed the first result.

Reproducible: Always
Steps to Reproduce:
1. type http://http://www.debian.org in the address bar
2. press enter
3. wait for www.microsoft.com to load

Actual Results:  
Microsoft homepage showed.

Expected Results:  
An error message would be more suitable

this happens to another person i know who uses mozilla firefox
this being an invalid URL, firefox does a "I'm feeling lucky" query on google.
the result of that query is microsoft.

*** This bug has been marked as a duplicate of 231720 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Assignee: general → firefox
Component: Browser-General → General
Product: Browser → Firefox
QA Contact: general → firefox.general
Version: Trunk → 1.0 Branch
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.