In-line style spec for link colors is not handled properly.

VERIFIED INVALID

Status

()

Core
Layout: Text
--
major
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: Robert Joy, Assigned: Blake Ross)

Tracking

1.4 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

In the index.html page there is a menu in the lower section of the page. The
style for links in the page have been established using a style tag, however
when the page is displayed in Firefox the coloring of the links uses the
defaults and not the colors specified in the style tag. MSIE DOES display this
properly.

Reproducible: Always
Steps to Reproduce:
1. Load the specified page.
2. Scroll to the area where the menus are.
3. Observer the coloration of the links in the left hand menu.

Actual Results:  
I observed that the links were hard to read and incorrectly colored.

Expected Results:  
Colored the links per the sytle tag.

Comment 1

13 years ago
I also experience this problem.  I'm working on a testcase.
Status: UNCONFIRMED → NEW
Component: General → Layout: Fonts and Text
Ever confirmed: true
Product: Firefox → Browser
Version: unspecified → 1.4 Branch

Comment 2

13 years ago
OK, the problem is that the web author made two errors:

<style TYPE="text/css">
<!--
a		{
	text-decoration: none  // NO ENDING ;
}

a:link	{
	color: "#C0C0C0";  // CSS DOSN"T SUPPORT "'s inline
	text-decoration: none;
}

a:active	{
	color: "#C0C0C0"; // CSS DOSN"T SUPPORT "'s inline
	text-decoration: none;
}

a:visited	{
	color: "#C0C0C0"; // CSS DOSN"T SUPPORT "'s inline
	text-decoration: none;
}
a:hover		{
	color: "#FFFF00"; // CSS DOSN"T SUPPORT "'s inline
	text-decoration: underline;
}
-->



I suggest you email the author of the page and warn them about this.  I'm
marking resolved fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 3

13 years ago
Fixed is for when a patch is introduced.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
robin:
ending ; is optional on the last declaration. note for example:
http://www.w3.org/TR/CSS21/syndata.html#declaration
also on that page, note "In between there must be a list of zero or more
semicolon-separated (;) declarations."
(Reporter)

Comment 5

13 years ago
I tested the page without the double quotes and it works on Firefox, however, 
we need to be smart about this, even though the CSS spec does not support the 
use of double quotes, the browser needs to be intelligent enough to "do the 
right thing". I propose that a fix be entered for this. As I mentioned, MSIE 
does handle this in a reasonable fashion. If you want developers to take this 
new browser seriously then it has to "do the right thing" too.
Status: RESOLVED → VERIFIED
> even though the CSS spec does not support the use of double quotes

It's not that it does not support it.  It's that it explicitly says that if you
encounter double quotes there you MUST ignore the declaration.  Anything else is
a bug in the browser.

> As I mentioned, MSIE does handle this in a reasonable fashion.

No, it does not.  The fact that it "handles" this is a cause of a number of CSS
parser bugs in MSIE.  We don't plan to introduce those parser bugs in Mozilla.
You need to log in before you can comment on or make changes to this bug.