activating the smooth scroll option produces high temperatures in memory controller G5 2.5GHz

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
--
minor
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Helmut Müller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

When activated the option smooth scrolling the temperature of the memory
controller suddenly produces peaks, forcing the fan to power up to 100% for a
few seconds, scrolling with this option checked forces the fan to work at 100%
for the whole time of scrolling.
Disabling this option makes the fan and the memory controller bahave as
expected, with scrolling and without.

Reproducible: Always
Steps to Reproduce:
1. activate option
2. scroll through a website
3. listen to the fan or check temp/fan with hardwaremonitor

Actual Results:  
It seems, that for whatever reason the memory controller is overloaded during
the scrolling. 

Expected Results:  
The SW should use only as much load on the chip as is required so that the fan
has not to power up to 100%.

I could mention, that due to the high main processor capacity of 2*2.5GHz some
timings inside the smooth scrolling code overload the memory controller
resulting in the described behaviour.

Comment 1

14 years ago
Related to Bug 202718? Does this happen with every page like Bugzilla listings?
(Reporter)

Comment 2

14 years ago
It could be, 202718 is Windows related, perhaps due to the dual processor system
whith hich prozessor clock (2.5GHz) and due to the high bus-clock (1.25GHz) on
the Mac G5 this leads to reported behaviour ? 

The CPU Load goes up, too - but the Memory Controller triggers the fan to speed
up ...

I don't know, how the timing is done within the smooth scrolling.

Comment 3

13 years ago
depend or dup bug236417?

Comment 4

13 years ago
This might be more info:  when I enable smooth scrolling on my HP Omnibook 4150b
the CPU runs at 100% more and sometimes the system locks up tight in mid-scroll
-- you can acttually see where the replicated lines are when it locks up. 

When I disable smooth scrolling, my system is much more stable.

ATI RAGE Mobility chipset.
Vendor ID from XP Pro SP2 device manager:
PCI\VEN_1002&DEV_4C4D&SUBSYS_000A103C&REV_64\4&415A68E&0&0008

Driver: 5.1.2001.0
Date: 6-Jun-2001 (Microsoft signed)

Comment 5

13 years ago
Most likely bug 141710, complicated with the extra cpu-power that you need to do smooth-scrolling.
Assignee: bugs → nobody
Helmut Müller: Is this still an issue with a recent release ?
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

9 years ago
Sorry Matthias, I obviously missed the mail from january and did not check bugzilla frequently.

Unfortunately I can not give it a try as I have changed my system, instead of the 2.5 PPC I now use a intel based mac mini. So I´m sorry...

regards, Helmut
You need to log in before you can comment on or make changes to this bug.