If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmark menu context menu accesskeys don't work

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
P3
minor
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: gkw, Unassigned)

Tracking

({access, helpwanted})

unspecified
x86
Windows XP
access, helpwanted
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041015 Firefox/0.10.1 (MOOX M2)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041015 Firefox/0.10.1 (MOOX M2)

Right click on bookmarks and then pressing "r" on keyboard should bring up
properties of that bookmark. Instead, the first bookmark in that folder with "r"
as the title letter is instigated in the current active tab.

Reproducible: Always
Steps to Reproduce:
1. Go bookmarks menu.
2. Right click on any bookmark in any sub-menu.
3. Click "r" key on keyboard.
Actual Results:  
Context menu remains on screen while the first bookmark in that folder with "r"
as the title letter is instigated in the current active tab

Expected Results:  
Properties menu should appear with the context menu disappearing. Nothing should
happen in the current tab.

Default theme. Using Moox M2 Build 20041015 though. Not sure if it happens on
official builds though. No extensions.
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.0?

Updated

13 years ago
Severity: major → normal
(Reporter)

Comment 1

13 years ago
Default builds have this bug too.

Additional behaviour observed:
1. Not only properties, but "d" for delete also doesn't work.
2. If there is no bookmark starting with "r", nothing happens, context menu
stays on screen.
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20041025 Firefox/1.0

None of the accesskeys work, and keypresses are unpredictably passed down to the
bookmarks: sometimes "O" will do nothing, sometimes it will _O_pen in tabs.

See also bug 256073 - unable to trigger the context menu from the keyboard,
which is trying to morph into this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: access
Summary: Right click on bookmarks and then pressing "r" on keyboard should bring up properties → Bookmark menu context menu accesskeys don't work
vlad, you need a tracker somewhere for all of the "stupid things that our menu
code does" for your post-1.0 pleasure.

Workaround, use the arrow keys.  As a note, since the context menu can't
actually be invoked without the mouse, afaict, this isn't a big deal at present.
 If you can invoke it with the mouse, you don't need it to be keyboard-friendly.
 The alternate path that does work is to use manage bookmarks.

Not a 1.0 blocker, way too edge-case/risky, this has probably never worked anyway.
Severity: normal → minor
Flags: blocking-aviary1.0? → blocking-aviary1.0-
(Reporter)

Comment 4

13 years ago
Clicking "f" for refreshing live bookmark works though.
Assignee: vladimir → vladimir+bm
*** Bug 272755 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
Strange, should be investigated. Perhaps related to bug 257082.
Keywords: helpwanted
Priority: -- → P3

Comment 7

12 years ago
Still happens using Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1)
Gecko/20050813 Firefox/1.0+.  (Tested using the 'd' key in a context menu for a
bookmark in a folder on my toolbar.)
Assignee: vladimir+bm → nobody
(Reporter)

Comment 8

12 years ago
Can this make it in the trunk? Or there's nobody able to work on this until the new bookmarks API is ready in future releases?

Hoping for 1.9a1+ or 2.0+.
(Reporter)

Updated

12 years ago
Flags: blocking1.9a1?
*** Bug 315035 has been marked as a duplicate of this bug. ***
*** Bug 341394 has been marked as a duplicate of this bug. ***
*** Bug 341395 has been marked as a duplicate of this bug. ***
QA Contact: mconnor → bookmarks
*** Bug 352680 has been marked as a duplicate of this bug. ***
WFM using "r" on trunk Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070216 Minefield/3.0a3pre
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Flags: blocking1.9a1?
You need to log in before you can comment on or make changes to this bug.