I can't open .pdf attachments on some e-mail.

RESOLVED DUPLICATE of bug 77811

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 77811
13 years ago
13 years ago

People

(Reporter: Alessandro Zanon, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Thunderbird version 0.8 (20040913)

To read .pdf document I must save e-mail message as “mail_name.eml” and then 
open it with Outlook Express 6.
I can forward to you an e-mail example.
If you agree it please sends your mail address to zanon@lnl.infn.it


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
I have encountered the same problems, using TB 1.0 builds 2004-12-13 and 2004-12-10.
When I get an email containing a .pdf attachment, and apparently sent by Outlook
Express or Outlook, the only attachment displayed is a big "winmail.dat" file,
which contains the attachment (I can see it if I open it in a text editor). The
.pdf attachment doesn't appear at all in TB, and I have no way to open it (even
by saving the file as .eml and opening it in OE). 

IMHO, this is a major problem for people working with TB, and should be resolved
quickly. :-(

Comment 2

13 years ago
I forgot the following in my reply:
if somebody sends me several files attached to an email, one of which is a pdf
file, all of them are embedded in this "windmail.dat" file, and none of them can
be read. :-(

Using TB 1.0 build 2004-12-12 on Win XP Pro SP1.

Comment 3

13 years ago
is OE really sending the .pdf file as winmail.dat? Can you attach the message
source of such a message? Or e-mail one to me?

Comment 4

13 years ago
(In reply to comment #3)
> is OE really sending the .pdf file as winmail.dat? Can you attach the message
> source of such a message? Or e-mail one to me?

I just emailed you two emails with this problem. One has only a .pdf file
attached, and one both a .pdf and an .xls file.

Comment 5

13 years ago
this is just something Outlook is doing, encoding the attachment in ms-tnef
format, a proprietary format. I believe you can turn this off by telling Outlook
not to encode messages in microsoft rich text format, or something like that (or
maybe it has to happen on the server? anyway, google for ms-tnef and that should
tell you how to turn it off)

We might want to support ms-tnef if possible. There are some open source
programs that do this.

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 77811 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.