"Contacts" button doesn't stay pushed (or down)

RESOLVED FIXED in Thunderbird1.1

Status

--
trivial
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: tbertels+bugzilla, Assigned: mscott)

Tracking

({icon})

unspecified
Thunderbird1.1
x86
Windows XP
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla Thunderbird 0.8 (20040913)(Windows; U; Windows NT 5.1; rv:1.7.3)

In the message compose window, the contact button doesn't stay pushed (or down)
when the list of contacts is opened (like does the history and bookmarks buttons
in Firefox).

Reproducible: Always
Steps to Reproduce:
1. Write a new message
2. Push the conatcs button
Actual Results:  
The contacts button doesn't stay pushed (or down)

Expected Results:  
The should button should have stay pushed (...or down)

Comment 1

14 years ago
I can confirm this bug in Thinderbird version 0.9+ (20041107). Someone please
change the staus to "CONFIRMED".

This is something that would make Thunderbird look more polished, and should be
fixed before 1.0 comes out.
Flags: blocking-aviary1.0?
(Assignee)

Comment 2

14 years ago
please attach a screen shot. I have not idea what you are talking about! :)

this is not a stop ship bug
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 3

14 years ago
Created attachment 165568 [details]
Screenshot showing this bug

Here ya go. :)
(Assignee)

Comment 4

14 years ago
I still feel clueless even with the screen shot.

If i press the button the side bar swings open. Pressing it again, it closes.
The open/close state is properly persisted across instances of the compose window.

Comment 5

14 years ago
Created attachment 165676 [details]
Screenshot showing how Firefox does it right

Scott: the "function" of the sidebar opening and closing is not the issue. it
is the *button* *itself* that should have a depressed *state*.

In firefox, press the Bookmark sidebar button to display the bookmarks sidebar,
then look at the bookmarks *button*. ;)

Comment 6

14 years ago
BTW, I really like how the bookmark button changes its *appearance* when it is
pressed. This adds to the ability to quickly determine the button's state. This
guves *two* visual clues: (1) depressed appearance, (2) "opened" book.
(Reporter)

Comment 7

14 years ago
Created attachment 185641 [details] [diff] [review]
Add a second state (pushed) to the "Contacts" button

This one does what is requested by the bug summary.
The next one adds the ability to have a different icon for the "pushed" state
(need an new icon).
Attachment #185641 - Flags: review?(ducarroz)
(Reporter)

Comment 8

14 years ago
Created attachment 185642 [details] [diff] [review]
Add the ability to have a different icon for the "pushed" state
Attachment #185642 - Flags: review?(ducarroz)

Comment 9

14 years ago
Thomas: 
1. You should make you diff against the trunk (I'm guessing that's the aviary
branch or something).
2. You should request review from someone other than ducarroz, who is no longer
active.  mscott would probably be better.
(Reporter)

Comment 10

14 years ago
Created attachment 185644 [details] [diff] [review]
Add a second state (pushed) to the "Contacts" button
Attachment #185641 - Attachment is obsolete: true
Attachment #185644 - Flags: review?(mscott)
(Reporter)

Comment 11

14 years ago
Created attachment 185645 [details] [diff] [review]
Add the ability to have a different icon for the "pushed" state

I didn't realize I was making a patch with the 1.0.2 version from the CVS.
Thank you for the tips, Andrew!
Attachment #185642 - Attachment is obsolete: true
Attachment #185645 - Flags: review?(mscott)
(Reporter)

Updated

14 years ago
Attachment #185644 - Attachment description: Add a second state (pushed) to the "Contacts" button 2 → Add a second state (pushed) to the "Contacts" button
Comment on attachment 185644 [details] [diff] [review]
Add a second state (pushed) to the "Contacts" button

Looks good to me. R=ducarroz
Attachment #185644 - Flags: superreview?(mscott)
Attachment #185644 - Flags: review?(mscott)
Attachment #185644 - Flags: review+
Comment on attachment 185645 [details] [diff] [review]
Add the ability to have a different icon for the "pushed" state

R=ducarroz
Attachment #185645 - Flags: superreview?(mscott)
Attachment #185645 - Flags: review?(mscott)
Attachment #185645 - Flags: review+

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

14 years ago
Attachment #185641 - Flags: review?(ducarroz)
(Reporter)

Updated

14 years ago
Attachment #185642 - Flags: review?(ducarroz)
(Reporter)

Updated

14 years ago
Keywords: icon
(Reporter)

Updated

14 years ago
Component: Mail Window Front End → Message Compose Window
(Assignee)

Updated

14 years ago
Attachment #185644 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 14

14 years ago
Comment on attachment 185645 [details] [diff] [review]
Add the ability to have a different icon for the "pushed" state

there's no need for this style rule since it isn't displaying a different image
here.
Attachment #185645 - Flags: superreview?(mscott) → superreview-
(Assignee)

Comment 15

14 years ago
I've checked this into 1.1, thanks for the fix!
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird1.1
(Reporter)

Comment 16

14 years ago
(In reply to comment #14)
> there's no need for this style rule since it isn't displaying a different image
> here.

Actually, a new icon is needed for the second state. Do I need to open a new bug
for it?
You need to log in before you can comment on or make changes to this bug.