IT/sv/ru/pl not included in regionNames.properties

RESOLVED FIXED

Status

()

Core
Internationalization
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Ervin Yan, Assigned: Ervin Yan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.7) Gecko/20041004
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.7) Gecko/20041004

dowload all spellchecking modules from:
http://dictionaries.mozdev.org/

Reproducible steps:
1. start Mozilla composer
2. click menu "Edit|Check Spelling"
3. click "Language:" combo box.

You will see it-IT/sv-SE/ru-RU/pl-PL not translated.

which means need include IT/sv/ru/pl in file: 
xpfe/global/resources/locale/en-US/regionNames.properties


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

13 years ago
Created attachment 163404 [details] [diff] [review]
patch to include it/pl/ru/se in regionNames.properties
Thank you for the patch. Please patch also toolkit/locale/regionNames.properties
and attach a contextual diff (made with diff -u).
Assignee: smontagu → Ervin.Yan
(Assignee)

Comment 3

13 years ago
Created attachment 163512 [details] [diff] [review]
new patch
Attachment #163404 - Attachment is obsolete: true
(Assignee)

Comment 4

13 years ago
Comment on attachment 163512 [details] [diff] [review]
new patch

could you review the patch?
Attachment #163512 - Flags: review?(smontagu)
Comment on attachment 163512 [details] [diff] [review]
new patch

r=smontagu
Attachment #163512 - Flags: review?(smontagu) → review+
(Assignee)

Updated

13 years ago
Attachment #163512 - Flags: superreview?(dbaron)
Comment on attachment 163512 [details] [diff] [review]
new patch

The rest of the file uses tabs, so please use tabs.  Otherwise, sr=dbaron,
although please check with bsmedberg before landing because of the aviary
branch merging.
Attachment #163512 - Flags: superreview?(dbaron) → superreview+
(Assignee)

Comment 7

13 years ago
Created attachment 166998 [details] [diff] [review]
patch to follow dbaron's comments.

Comment 8

13 years ago
In addition to the two places already listed, please also land this patch in

toolkit/locales/en-US/chrome/global/regionNames.properties
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

13 years ago
Created attachment 167313 [details] [diff] [review]
patch to follow bsmedberg's comments
(Assignee)

Updated

13 years ago
Attachment #163512 - Attachment is obsolete: true
Attachment #166998 - Attachment is obsolete: true
(Assignee)

Comment 10

13 years ago
bsmedberg: do you have any other concerns for landing this patch?

Comment 11

13 years ago
It looks fine to me.
(Assignee)

Comment 12

13 years ago
Created attachment 168397 [details] [diff] [review]
patch to follow the latest change in cvs trunk

toolkit/locale/regionNames.properties is removed in latest trunk.
Attachment #167313 - Attachment is obsolete: true
(Assignee)

Comment 13

13 years ago
patch landed. thanks simford.dong for help to check in the patch.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.