Proposition for french localisation of search plugins

RESOLVED FIXED

Status

Mozilla Localizations
fr / French
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Bugzilla FR, Assigned: David Bellot)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: search-engines)

Attachments

(7 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.3) Gecko/20041022 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.3) Gecko/20041022 Firefox/1.0


Here are our proposals to localize the search plugins in French. In some cases
we would want to include twice the same thing, but one for France (which is
usually also suitable for Belgium, Luxembourg and Switzerland) and another for
Québec (Canada).

* Google: localize the plugin by adding the parameter "&hl=fr" which brings the
interface to French but doesn't affect the search results (while providing an
option to search only in french-speaking websites)

* Yahoo: make two plugins of that, one searching in fr.yahoo.com (Yahoo! France)
; and another one searching in cf.yahoo.com (Yahoo! Canada in French). The
results are different.

* Amazon.com: again, two plugins: amazon.fr (prices in EUR, shipping in Europe)
and amazon.ca. The books are different, and so are the prices (EUR vs. CDN$) and
shipping costs.

* Dictionary.com: replace by TLFi <http://atilf.atilf.fr/> which seems to be the
only dictionary in French for which a plugin could be made (but it seems to use
the POST method instead of GET)

* eBay : drop this plugin completely for now, as few people seems to be
interested in eBay (alternatively, could be splitted in ebay.fr and ebay.be)

That would make 6 plugins; up to 8 if eBay is to be included.


Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
> * Dictionary.com: replace by TLFi <http://atilf.atilf.fr/> which seems to be the
> only dictionary in French for which a plugin could be made (but it seems to use
> the POST method instead of GET)

This will not be possible, the site requires an open session to work properly
(which we had when doing preliminary testing). We will probably want to keep
dictionary.com for 1.0.

The other requests are still valid.

Comment 2

14 years ago
Created attachment 164376 [details] [diff] [review]
Google with hl=fr

This brings the Google.com interface to French, adding a checkbox basically
saying "search in french pages only".

Not sure about the updateurl field, maybe it should be changed as well, to not
be overwritten.

Comment 3

14 years ago
Created attachment 164378 [details]
Amazon.fr plugin (from mycroft.mozdev.org)

The icon is the same as amazondotcom.png

Comment 4

14 years ago
Created attachment 164380 [details]
Yahoo! Canada in French

This is a copy of the Yahoo.fr plugin, with "fr" replaced by "cf". Icon is the
same too.

Comment 5

14 years ago
Created attachment 164381 [details]
Amazon.ca plugin (from mycroft.mozdev.org)

Only some parts of the site are localized, search results are always shown in
english (not the plugin fault, the site does that in its own search box even if
the language cookie is set), but books and movies are actually available in the
French language.

Comment 6

14 years ago
Comment on attachment 164376 [details] [diff] [review]
Google with hl=fr

Not necessary. Google uses accept-language settings by default.
Attachment #164376 - Attachment is obsolete: true

Comment 7

14 years ago
Created attachment 164393 [details]
Dictionary.com plugin replacement proposal (Voila.fr)

Finally found a suitable replacement for dictionary.com, was tested with
accentuated characters too (hand-made plugin). Subject to l10n policy approval
since it is not only a localized version of an existing plugin but a different
one.

Comment 8

14 years ago
Created attachment 164394 [details]
Icon for Voila.fr dictionary

Icon for the proposed dictionary plugin (took the favicon.ico from the site,
and converted it to a PNG with transparent background).

Comment 9

14 years ago
Created attachment 164398 [details]
Plugin for eBay.be in French

Based on the dutch eBaybe plugin by localhost available on mycroft.mozdev.org.

Comment 10

14 years ago
Created attachment 164399 [details]
eBay.fr plugin

eBay.fr plugin, based on eBay.src.

Comment 11

14 years ago
Moving to Marketing > Trademark Permissions as this is needed for at least one
of the plugins (Voila.fr).

Summary for easier read:

* Google: leave as it is.

* Yahoo: 
- Leave as it is (corrected by Ben Goodger), maybe just rename to Yahoo! France
- But add Yahoo! Canada

* Amazon:
- Localize using Amazon.fr
- And add Amazon.ca

* Dictionary.com: Replace with Voila.fr

* eBay:
- Localize using eBay.fr
- And add eBay.be in French
Assignee: bugs → bart
Component: Installer → Trademark Permissions
Product: Firefox → Marketing
(Reporter)

Comment 12

14 years ago
We need approval before 1.0 release of firefox :)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

14 years ago
rafael, I can't decide on the canada/france mix here. We need your input here.

Comment 14

14 years ago
It would be great if we could at least get an approval on the dictionary change
if the "duplication" of some search engines causes a problem because it was not
envisioned before.

Updated

14 years ago
Whiteboard: search-engines
(Reporter)

Updated

14 years ago
Status: NEW → ASSIGNED
comments:
1) for amazon plug-in, okay to change to Amazon.fr
<input name="tag" value="edazzledotn01-21"> needs to be value="mozilla-20"

2) Dictionary.com can be changed to Voila.fr

3) eBay.fr change is fine.

These are to replace the Amazon US, Dictionary.com, and eBay US.

So final list should be:
- Google
- Yahoo
- Amazon.fr
- eBay.fr
- Voila.fr
comments:
1) for amazon plug-in, okay to change to Amazon.fr
<input name="tag" value="edazzledotn01-21"> needs to be value="mozilla-20"

2) Dictionary.com can be changed to Voila.fr

3) eBay.fr change is fine.

These are to replace the Amazon US, Dictionary.com, and eBay US.

So final list should be:
- Google
- Yahoo
- Amazon.fr
- eBay.fr
- Voila.fr

Assignee: bart → filip
Status: ASSIGNED → NEW

Comment 17

14 years ago
Created attachment 165047 [details]
Updated Amazon.fr with the mozilla-20 tag
Attachment #164378 - Attachment is obsolete: true

Updated

14 years ago
Attachment #165047 - Attachment is patch: false

Comment 18

14 years ago
Bringing back to Mozilla Localizations in order to ask approval on the changes.
Assignee: filip → bellot
Component: Trademark Permissions → French/fr-FR
Product: Marketing → Mozilla Localizations
QA Contact: bugzilla → bellot

Comment 19

14 years ago
Changes checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.