Restoring Firefox from minimized state collapses bookmark toolbar

VERIFIED DUPLICATE of bug 266737

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 266737
14 years ago
13 years ago

People

(Reporter: Pavel Penaz, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041025 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041025 Firefox/1.0

Sorry for the poor summary, I could not think of right words to describe this bug.

Reproducible: Always
Steps to Reproduce:
1. Minimize Firefox window (you have to have at least one bookmark in bookmark
toolbar)
2. Change desktop colour depth from 32 to 16bit colours or vice versa
3. Restore Firefox window

Actual Results:  
Bookmarks toolbar is collapsed to the left side

Expected Results:  
Bookmarks in bookmark toolbar should be visible

I'll attach screenshot in a minute..
(Reporter)

Comment 1

14 years ago
Created attachment 163475 [details]
Screenshot

Bookmark toolbar is collapsed to the left
Attachment #163475 - Attachment description: testcase → Screenshot
(Reporter)

Comment 2

14 years ago
It just happened to me again, without me even changing the color depth. So
perhaps there are more ways to reproduce this bug. It happens to me perhaps
every other day. The only way for me to reliably reproduce this issue is still
the change of color depth, every other occurence of this was too random..
(Reporter)

Comment 3

14 years ago
I found another way how to reproduce this bug..

Reproducible: Always
Steps to Reproduce:
1. Minimize or restore Firefox window (it must be anything but maximized)
2. Launch a new application, for instance Internet Explorer (this is not
required if FF is minimized)
3. Switch to another user using Fast-user-switching in WinXP
4. Switch back to the original user's account

Actual results:
Firefox bookmarks toolbar is collapsed to the left (see the attached screenshot)
Confirmed using the original steps as well as when switching from 16 bit to 32
bit color depth. I also have additional buttons on my bookmarks toolbar and they
were still present while my bookmarks had disappeared.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I was unable to reproduce this with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041031
Firefox/0.9.1+
or
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041028
so it appears to be limited to the branch at this time

Comment 7

14 years ago
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3)
Gecko/20041029 Firefox/1.0RC1

Used the steps listed in first comment. Also to notice, I have my actual
bookmarks toolbar turned off, and my actual bookmarks moved into my navigation
toolbar. The same thing happens. I also have weatherfox installed to show on
that toolbar to the right of boookmarks. Not sure if that would affect it or
not. Will try without weatherfox later.

Comment 8

14 years ago
Created attachment 164341 [details]
Bug on Nav toolbar

Disabled all my extensions and I still see this bug. Also to note is that you
can get them "back" by hitting restore and then maximizing. Attached is in
1600x1200 when the bookmarks are actually on the navigation toolbar. 

What resolutions is everyone else running at just to quickly rule that out?

Comment 9

14 years ago

*** This bug has been marked as a duplicate of 266737 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: Change of desktop colour depth when Firefox is minimized collapses bookmark toolbar → Restoring Firefox from minimized state collapses bookmark toolbar
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.