Charset menu under "more" has extra menu item in Mac

VERIFIED WORKSFORME

Status

()

Core
Internationalization
P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: Teruko Kobayashi, Assigned: cata)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
This is related bug to 24029.

In mac, under "more" character menu, there are extra menu items as follows.
      hz-gb-2312
      t.61-8bit
      us-ascii
      utf-16be
      utf-16le
      utf-32be
      utf-32le
      Windows-936 
      and x-xxxx items

These items are not included under "more" charset menu in Win32 and Linux build.

Tested 2000020410 Mac build.
(Reporter)

Comment 1

19 years ago
Changed QA contact to amasri@netscape.com
QA Contact: teruko → amasri

Comment 2

19 years ago
This looks like a problem with "charsetData.properties" file. teruko, do you 
have this file in the same directory as charsetalias.properties directory ? It 
should under the "res" directory of the binary.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14
(Reporter)

Comment 3

19 years ago
Both "charsetData.properties" file and "charsetalias.properties" are located in res directory.
(Assignee)

Comment 4

19 years ago
Are the "user friendly" names working on Mac?
(Assignee)

Comment 5

19 years ago
Frank's is probably right: the charsetData.properties file doesn't work. If the 
charsetTitle.properties file works, the mistery deepens.

Anyway, this looks like a Mac-only issue, and I don't have a Mac to 
investigate, but I'm willing to sit with someone and step through code. It 
should take me less than 1/2 hour to find the problem... Naoki, Frank, any 
takers? :)

Comment 6

18 years ago
somehow I cannot reproduce this in my local Mac build. Teruko, is this still 
reproduceable ? could be a packaging problem. 
(Assignee)

Comment 7

18 years ago
Teruko, please check if this bug is still valid and let's close it if everything 
is all right.
(Assignee)

Comment 8

18 years ago
Teruko, can you please check this bug ASAP? We need to close it by today if it 
is no longer valid, or to investigate if it is...
(Reporter)

Comment 9

18 years ago
This does not happen in 2000021112 Mac build.  I mark this as worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 10

18 years ago
verified
Status: RESOLVED → VERIFIED

Updated

14 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.