diff native file pickers on linux?

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: pavlov)

Tracking

({platform-parity})

Trunk
Other
Linux
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
noticed this on the comm bits from 2000-02-04-08.

go to File > Open File. the resulting native file picker has

* "Open File" in the title bar
* Create Dir, Delete File, Rename File buttons
* droplist showing current dir
* two lists, one for dirs and one for files
* droplist with "All Files" which doesn't drop down
* text field below Selection description
* OK and Cancel buttons

for comparison (you'll need to close the previous dialog if you have it already
up; it's modal) go to File > Open Web Location, then click Choose File button,
which brings up another native file picker. it's identical to the one above,
except that the titlebar has "Choose File."

so, how different are these two dialogs? is it the same app being called? if
not, why not?
(Reporter)

Comment 1

19 years ago
added pp keyword. updated qa contact to me.

dependent on bug 26480 since that's a tracking bug to rehaul the native picker
in linux anyhow.
Depends on: 26480
Keywords: pp
QA Contact: paulmac → sairuh

Comment 2

19 years ago
This is a feature, not a bug.   The file picker dialog title is set by the 
JavaScript code opening the dialog.   The two dialogs have different functions, 
hence the title has been set differently.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

19 years ago
.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.